summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 585dd41a4ea8..2f703e206e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# URL: https://github.com/anaseto/boohu
# Upstream: https://github.com/anaseto/boohu
-pkgname=('boohu-git')
+pkgname=('boohu-git' 'boohu-tk-git')
pkgver=0.13.0.5.g9103191
pkgrel=1
pkgdesc="Break Out Of Hareka's Underground, a roguelike game."
@@ -23,16 +23,23 @@ pkgver() {
prepare() {
cd "$pkgname"
- go mod init "${url#https://}" # strip https:// from canonical URL
+ # strip https:// from canonical URL
+ go mod init "${url#https://}" || echo 'already modded'
go mod tidy
}
build() {
cd "$pkgname"
go build -o boohu .
+ go build --tags tk -o boohu-tk .
}
-package() {
+package_boohu-git() {
install -Dm 755 "$srcdir/$pkgname/boohu" -t "$pkgdir/usr/bin";
install -Dm 644 "$srcdir/$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
}
+
+package_boohu-tk-git() {
+ install -Dm 755 "$srcdir/boohu-git/boohu-tk" -t "$pkgdir/usr/bin";
+ install -Dm 644 "$srcdir/boohu-git/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
+}