summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f035026dfd8..0ff4af4522fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,41 @@
# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
pkgname=bookworm-git
-pkgver=1.1.1.r48.g3537e86
+pkgver=1.1.2.r179.g3b1cc9d
pkgrel=1
pkgdesc='A simple user centric eBook reader which displays multiple eBooks formats uniformly'
-arch=('x86_64')
+arch=(x86_64)
url='https://babluboy.github.io/bookworm'
-license=('GPL3')
-depends=('libgranite.so' 'poppler-glib' 'unarchiver' 'unzip' 'webkit2gtk')
-makedepends=('git' 'meson' 'vala')
+license=(GPL3)
+depends=(granite poppler-glib python unarchiver unzip webkit2gtk python-html2text)
+makedepends=(git meson vala ninja)
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("${pkgname%-*}::git+https://github.com/babluboy/bookworm.git")
-sha256sums=('SKIP')
+source=("${pkgname%-*}::git+https://github.com/babluboy/bookworm.git"
+ 'html2text.patch')
+sha256sums=('SKIP'
+ 'a90f0753d54aa8f3b72816494928f8e9b72bf26fccd477adfa495e9e2c93dc42')
pkgver() {
cd "${pkgname%-*}"
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${pkgname%-*}"
+ patch -p1 < ../html2text.patch
+ mkdir build
+}
+
build() {
- arch-meson ${pkgname%-*} build -Db_pie=false
- ninja -C build
+ cd "${pkgname%-*}"
+ meson build --prefix=/usr
+ cd build
+ ninja
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ cd "${pkgname%-*}"/build
+ DESTDIR="$pkgdir" ninja install
+ install -m644 -D ../COPYING "$pkgdir"/usr/share/licenses/bookworm/COPYING
}