summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 39 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0015734e86b6..3c5af1d83cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,55 @@
# Maintaner: Francesco Masala <mail@francescomasala.me>
-# Contributor: Francesco Masala <mail@francescomasala.me>
+# Contributor: Francesco Masala <mail@francescomasala.me>
pkgname=bottles
-pkgver=2021.9.14
-pkgrel=1
+pkgver=51.11
+pkgrel=2
+epoch=2
pkgdesc='Easily manage wine and proton prefix'
arch=('x86_64')
url="https://github.com/bottlesdevs/Bottles"
license=('GPL3')
depends=(
- 'hicolor-icon-theme'
- 'dconf'
- 'python'
- 'libhandy'
- 'gtk3'
- 'patool'
- 'p7zip'
- 'python-gobject'
- 'python-requests'
- 'python-yaml'
- 'wine'
- 'cabextract')
+ 'cabextract'
+ 'dconf'
+ 'fvs'
+ 'gtk4'
+ 'gtksourceview5'
+ 'hicolor-icon-theme'
+ 'icoextract'
+ 'imagemagick'
+ 'lib32-gnutls'
+ 'libadwaita'
+ 'libhandy'
+ 'libportal-gtk4'
+ 'p7zip'
+ 'patool'
+ 'python'
+ 'python-chardet'
+ 'python-gobject'
+ 'python-markdown'
+ 'python-orjson'
+ 'python-pathvalidate'
+ 'python-pycurl'
+ 'python-requests'
+ 'python-steamgriddb'
+ 'python-yaml'
+ 'webkit2gtk'
+ 'xorg-xdpyinfo'
+ 'vkbasalt-cli'
+)
optdepends=(
+ 'gamemode'
'gvfs'
- 'vkd3d'
'lib32-vkd3d'
'lib32-vulkan-icd-loader'
+ 'vkd3d'
'vulkan-icd-loader'
- 'gamemode')
-makedepends=('meson' 'ninja')
-source=("${pkgname}-${pkgver}-treviso.tar.gz::https://github.com/bottlesdevs/Bottles/archive/${pkgver}-treviso.tar.gz")
-sha256sums=('d66b9589164cd256064faefcb825d898c8e57099caddfca60267f67f93e65065')
+ 'wine'
+)
+makedepends=('meson' 'ninja' 'blueprint-compiler')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bottlesdevs/Bottles/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('3e438e98fdc3821e250a0c583e74d203e7c05511c0892587a5a29dd886392f3c')
build() {
if [[ -d Bottles ]]; then