summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 30 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ceecccade29..ebbf9a8f3584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,49 @@
# Contributor: Francesco Masala <mail@francescomasala.me>
pkgname=bottles
-pkgver=2022.5.28
-pkgrel=5
+pkgver=2022.8.28
+pkgrel=1
epoch=1
pkgdesc='Easily manage wine and proton prefix'
arch=('x86_64')
url="https://github.com/bottlesdevs/Bottles"
license=('GPL3')
depends=(
+ 'cabextract'
+ 'dconf'
+ 'fvs'
+ 'gtk4'
+ 'gtksourceview5'
+ 'hicolor-icon-theme'
+ 'icoextract'
+ 'imagemagick'
'lib32-gnutls'
- 'gtksourceview4'
- 'hicolor-icon-theme'
- 'dconf'
- 'python'
- 'libhandy'
- 'gtk3'
- 'patool'
- 'p7zip'
- 'python-gobject'
- 'python-requests'
- 'python-yaml'
+ 'libadwaita'
+ 'libhandy'
+ 'libportal-gtk4'
+ 'p7zip'
+ 'patool'
+ 'python'
+ 'python-gobject'
'python-markdown'
- 'wine'
- 'cabextract'
+ 'python-orjson'
+ 'python-pillow'
+ 'python-requests'
+ 'python-steamgriddb'
+ 'python-yaml'
'webkit2gtk'
- 'xorg-xdpyinfo'
- 'icoextract')
+ 'xorg-xdpyinfo')
optdepends=(
+ 'gamemode'
'gvfs'
- 'vkd3d'
'lib32-vkd3d'
'lib32-vulkan-icd-loader'
- 'vulkan-icd-loader'
- 'gamemode')
-makedepends=('meson' 'ninja')
-source=("${pkgname}-${pkgver}-trento-3.tar.gz::https://github.com/bottlesdevs/Bottles/archive/${pkgver}-trento-3.tar.gz")
-sha256sums=('07d8a054abfe8393ae8115761ce4a709735ebb4455a2a923785c9d2ae042949f')
+ 'vkd3d'
+ 'wine'
+ 'vulkan-icd-loader')
+makedepends=('meson' 'ninja') # 'blueprint-compiler' will be needed since 2022.9.28
+source=("${pkgname}-${pkgver}-brescia-2.tar.gz::https://github.com/bottlesdevs/Bottles/archive/${pkgver}-brescia-2.tar.gz")
+sha256sums=('85d83092f1b8884650811009ca601741b801b482f2c6bf974b0ccb4c42c02b15')
build() {
if [[ -d Bottles ]]; then