summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1682c33cd4b..92e8eca5a363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
pkgname=boxtron-git
_pkgname="${pkgname%-git}"
pkgver=0.5.3.r6.8aa2e4e
-pkgrel=1
+pkgrel=2
pkgdesc='Compatibility tool to run DOS games on Steam through native Linux DOSBox'
arch=('i686' 'x86_64')
url="https://github.com/dreamer/$_pkgname"
license=('GPL')
depends=('python' 'dosbox' 'inotify-tools' 'timidity++')
makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
optdepends=(
'steam: The Steam client'
'soundfont-fluid: required for MIDI support, but another soundfont can be used')
@@ -20,12 +22,6 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
-prepare() {
- cd "$_pkgname"
- sed -i -E '/^tool_(name|dir) +=/s/$/-git/' Makefile
- sed -i -E '/^tool_name_display +=/s/$/ (git)/' Makefile
-}
-
check() {
cd "$_pkgname"
make test