summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 17 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 937def30b6df..52eb0f6dcc9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=brackets
pkgver=1.14.1
-pkgrel=1
+pkgrel=2
_cef_ver=3.2785.1486
_node_ver=6.11.0
pkgdesc="An open source code editor for the web, written in JavaScript, HTML and CSS."
@@ -25,7 +25,11 @@ source=("git+https://github.com/adobe/brackets#tag=release-${pkgver//_/-}"
"jslint::git+https://github.com/peterflynn/JSLint"
"git+https://github.com/jrburke/requirejs"
"mustache::git+https://github.com/janl/mustache.js"
- 'https://patch-diff.githubusercontent.com/raw/adobe/brackets-shell/pull/648.patch'
+ "git+https://github.com/requirejs/i18n"
+ "git+https://github.com/requirejs/text"
+ "git+https://github.com/jblas/path-utils.git"
+ "git+https://github.com/mustache/spec"
+ "https://patch-diff.githubusercontent.com/raw/adobe/brackets-shell/pull/648.patch"
"http://s3.amazonaws.com/files.brackets.io/cef/cef_binary_${_cef_ver}_linux64_release.zip"
"http://nodejs.org/dist/v${_node_ver}/node-v${_node_ver}-linux-x64.tar.gz"
"https://github.com/adobe/brackets/releases/download/release-${pkgver}/Brackets.Release.${pkgver}.64-bit.deb"
@@ -36,6 +40,10 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'4421e27e2e333a14b9f1dd3bea4248a6'
'9b1364b60786a595076f9da789512685'
'e6ade07945c32f82da184ebbcb5347dc'
@@ -46,10 +54,16 @@ prepare() {
cd ${srcdir}/${pkgname}
git config submodule.src/extensions/default/JSLint/thirdparty/jslint.url "$srcdir/jslint"
- for i in mustache requirejs
+ for i in i18n mustache path-utils requirejs text
do
git config submodule.src/thirdparty/${i}.url "$srcdir/$i"
done
+ git submodule update --init
+
+ cd ${srcdir}/${pkgname}/src/thirdparty/mustache
+ git config submodule.test/spec.url "$srcdir/spec"
+ git submodule update --init
+
git submodule update --init --recursive
cd ${srcdir}/brackets-shell