summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..834f40d5791f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Benjamin James <benjamin-james@utulsa.edu>
+
+pkgname=brainfuck
+pkgver=0.1
+pkgrel=1
+pkgdesc="A full fledged brainfuck compiler"
+arch=('any')
+url="https://github.com/benjamin-james/brainfuck"
+license=('GPL3')
+depends=('glibc' 'binutils')
+provides=('bfc')
+source=(https://github.com/benjamin-james/${pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('22dd272219ee951739937f1548c4448d')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" PREFIX="/usr" install
+}