summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 15 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4fa29d172e4..82dfc55d655e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,8 +27,8 @@ fi
##
pkgname=brave
-pkgver=1.22.72
-pkgrel=2
+pkgver=1.23.71
+pkgrel=1
pkgdesc='A web browser that stops ads and trackers by default'
arch=('x86_64')
url='https://www.brave.com/download'
@@ -40,8 +40,8 @@ optdepends=('cups: Printer support'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: for storing passwords in KWallet on KDE desktops'
'sccache: For faster builds')
-chromium_base_ver="89"
-patchset="7"
+chromium_base_ver="90"
+patchset="6"
patchset_name="chromium-${chromium_base_ver}-patchset-${patchset}"
_launcher_ver=7
source=("brave-browser::git+https://github.com/brave/brave-browser.git#tag=v${pkgver}"
@@ -53,13 +53,12 @@ source=("brave-browser::git+https://github.com/brave/brave-browser.git#tag=v${pk
'brave-browser.desktop'
"chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz"
"https://github.com/stha09/chromium-patches/releases/download/${patchset_name}/${patchset_name}.tar.xz"
- "chromium-no-history.patch" "chromium-no-history2.patch")
-arch_revision=199ffbc9f0bd6d902fd2e077b20ff9fa50ae9307
+ "chromium-no-history.patch")
+arch_revision=8d3870e027300e243471b1e508f31d16ce45553a
Patches="
- add-dependency-on-opus-in-webcodecs.patch
+ add-clang-nomerge-attribute-to-CheckError.patch
chromium-glibc-2.33.patch
use-oauth2-client-switches-as-default.patch
- chromium-fix-libva-redef.patch
"
for arch_patch in $Patches
do
@@ -74,13 +73,11 @@ sha256sums=('SKIP'
'725e2d0c32da4b3de2c27a02abaf2f5acca7a25dcea563ae458c537ac4ffc4d5'
'fa6ed4341e5fc092703535b8becaa3743cb33c72f683ef450edd3ef66f70d42d'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
- 'f8b1558f6c87b33423da854d42f0f69d47885a96d6bf6ce7f26373e93d47442f'
+ '3eb9580ea35a96789e02815270498226fa33726f4210a5ee36f3868af2ffae1f'
'ea3446500d22904493f41be69e54557e984a809213df56f3cdf63178d2afb49e'
- 'd7775ffcfc25eace81b3e8db23d62562afb3dbb5904d3cbce2081f3fe1b3067d'
- 'b86b11de8db438c47f0a84c7956740f648d21035f4ee46bfbd50c3348d369121'
+ '5e22afcb91b5402bc09e80630c5323d61013c3fccb0bbd9b23d1e79a400b00d0'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
- 'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
- 'de9eb3612d44616a500c2eccdffac814eb90ad9a868cc1030d17fc6783d544e2')
+ 'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -109,7 +106,7 @@ _unwanted_bundled_libs=(
# Add depends if user wants a release with custom cflags and system libs
if [ "$COMPONENT" = "4" ]; then
- #echo "Build with system libs is disabled for now" && exit 1
+ echo "Build with system libs is disabled for now" && exit 1
brave_base_ver="$(echo $pkgver | cut -d . -f 1-2)"
brave_patchset="1"
brave_patchset_name="brave-${brave_base_ver}-patches-${brave_patchset}"
@@ -147,8 +144,6 @@ prepare() {
cp -r "${srcdir}"/depot_tools src/brave/vendor/
cp -rT "${srcdir}"/adblock-rust src/brave/vendor/adblock_rust_ffi
- #patch -Np1 -i ../chromium-no-history2.patch
-
msg2 "Running \"npm run\""
if [ -d src/out/Release ]; then
npm run sync -- --force
@@ -173,12 +168,12 @@ prepare() {
# https://crbug.com/1164975
patch -Np1 -i ../../chromium-glibc-2.33.patch
- # Upstream fixes
- patch -Np1 -i ../../add-dependency-on-opus-in-webcodecs.patch
+ # Revert addition of [[clang::nomerge]] attribute; not supported by clang 11
+ patch -Rp1 -d base <../../add-clang-nomerge-attribute-to-CheckError.patch
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../../patches/chromium-89-quiche-dcheck.patch
- patch -Np1 -i ../../patches/chromium-89-AXTreeSerializer-include.patch
+ patch -Np1 -i ../../patches/chromium-90-quantization_utils-include.patch
+ patch -Np1 -i ../../patches/chromium-90-TokenizedOutput-include.patch
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
@@ -191,9 +186,6 @@ prepare() {
sed -i 's/OFFICIAL_BUILD/GOOGLE_CHROME_BUILD/' \
tools/generate_shim_headers/generate_shim_headers.py
- # https://github.com/kiss-community/repo-community/issues/246
- patch -Np1 -i ../../chromium-fix-libva-redef.patch
-
msg2 "Add patches for custom build"
for _patch in "$srcdir/brave-patches-$brave_patchset_name"/*.patch; do
patch -Np1 -i "$_patch"