summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..549600b893c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Mark Doe <mark.doe.priv@gmail.com>
+# Contributor: Benjamin Bukowski <crankidiot(at)gmail.com>
+
+_printer=mfc6490cw
+pkgname=brother-${_printer}-lpr
+pkgver=1.1.2_2
+_version=${pkgver//_/-}
+pkgrel=3
+pkgdesc="LPR driver for Brother MFC-6490CW multifunction network printer"
+arch=('i686' 'x86_64')
+url="http://solutions.brother.com/linux/en_us/download_prn.html#MFC-6490CW"
+license=('GPL')
+depends=('tcsh')
+source=("http://download.brother.com/welcome/dlf006180/${_printer}lpr-${_version}.i386.deb")
+md5sums=('781e72e8e451bbdb4db39a0967ec1dd6')
+
+package() {
+ cd $srcdir
+
+ ar x ${_printer}lpr-${_version}.i386.deb || return 1
+ [ ! -d "data" ] && mkdir data
+ tar -xzvf data.tar.gz -C data || return 1
+
+ [ ! -d "data/usr/share" ] && mkdir data/usr/share
+ mv data/usr/local/Brother data/usr/share/brother
+ rm -r data/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' data/` || return 1
+
+ cp -r data/usr $pkgdir || return 1
+}