summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63aee17514e7..882057113e5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+#
pkgname=bviplus
-pkgver=0.9.4
-pkgrel=3
+pkgver=1.0
+pkgrel=1
pkgdesc="An ncurses based hex editor with a vim-like interface."
arch=('i686' 'x86_64')
url="http://bviplus.sourceforge.net/"
license=("GPL3")
depends=("ncurses")
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tgz")
-md5sums=('b814929c439d2ec75cec2597540003e7')
+md5sums=('7e9f588679ecd200c64881396c302b8b')
prepare() {
cd ${pkgname}-${pkgver}
cp vf_backend.c vf_backend.c.orig
sed -i -r 's,inline (void compute_percent_complete),\1,' vf_backend.c
+ cp Makefile Makefile.orig
+ sed -i -r 's,(\$\(EXTRA_CFLAGS\) \$\^),\1 $(LDFLAGS),' Makefile
+
}
build() {