summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a765f12fc297..b48a75d33525 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
pkgname=cardano-sl
-pkgver=3.0.1
-_commit=57a0d236eed59c48214ee70128549d6cfdbc73db
+pkgver=3.1.0
+_commit=1a792d7cd0f0c93a0f0c28f66372bce3c3808dbd
pkgrel=1
pkgdesc='Cryptographic currency implementing Ouroboros PoS protocol'
arch=('x86_64')
@@ -10,8 +10,16 @@ url='https://github.com/input-output-hk/cardano-sl/'
license=('MIT')
depends=('gmp' 'openssl' 'rocksdb')
makedepends=('git' 'stack')
-source=("git+https://github.com/input-output-hk/cardano-sl.git#commit=${_commit}")
-sha256sums=('SKIP')
+source=("git+https://github.com/input-output-hk/cardano-sl.git#commit=${_commit}"
+ 'stack.patch')
+sha256sums=('SKIP'
+ '5a3930f42dc369cfcd993537bde79cf69e80e48a5aeaf599fd38371af614f2fa')
+
+prepare() {
+ cd ${pkgname}
+
+ patch -Np1 -i ../stack.patch
+}
build() {
cd ${pkgname}