summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6160443d3b8d..5f11117dc45c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id: PKGBUILD 137547 2015-07-28 09:44:47Z arodseth $
# Maintainer: Brian Bidulock <bidulock@openss7.org>
# Contributor: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Valère Monseur (valr) <valere dot monseur at ymail dot com>
@@ -6,17 +5,22 @@
pkgname=cbatticon-gtk2
_pkgname=cbatticon
pkgver=1.6.10
-pkgrel=1.1
+pkgrel=3
pkgdesc='Lightweight battery icon for the system tray (gtk2)'
-arch=(x86_64 i686)
+arch=(x86_64 i686 armv7h)
url='https://github.com/valr/cbatticon'
license=(GPL2)
-depends=(libnotify gtk2)
+depends=(gtk2 libnotify)
provides=(cbatticon=${pkgver}-${pkgrel%%.*})
conflicts=(cbatticon)
source=("$_pkgname-$pkgver.tar.gz::https://github.com/valr/$_pkgname/archive/$pkgver.tar.gz")
sha256sums=('c9782e86dab64bea17583640f23e9fda34682967984f2105aa21e0d1c355cd57')
+prepare() {
+ cd $_pkgname-$pkgver
+ sed -i -e "s;-Wno-format;$CFLAGS;" Makefile
+}
+
build() {
make -C "$_pkgname-$pkgver" WITH_NOTIFY=1 WITH_GTK3=0
}