summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 27 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd38ef6b0fae..93efb016f807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
-# Maintainer: Sébastien Luttringer <sebastien.luttringer@arkena.com>
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=cc-cli
-pkgver=7
-pkgrel=4
-pkgdesc='CloudControl Command Line Interface'
-arch=('any')
-url='https://git.seblu.net/mirror/cc-cli'
-license=('GPL2')
-depends=('python2' 'python2-sjrpc' 'python2-xdg')
-makedepends=('git' 'python2-setuptools')
-source=("git+https://git.seblu.net/mirror/cc-cli.git#tag=v$pkgver")
-md5sums=('SKIP')
+pkgver=0.1.5
+pkgrel=1
+pkgdesc='handy git-hook and cli for conventional commits'
+arch=('arm' 'armv6h' 'armv7h' 'aarch64' 'i686' 'x86_64')
+url='https://github.com/sousandrei/cc-cli'
+license=('GPL3')
+depends=('gcc-libs' 'openssl')
+makedepends=('rust')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/sousandrei/${pkgname}/archive/v${pkgver}.tar.gz")
+b2sums=('5203b76a6a57e54edaba9465b5a463396793238c876443044bc24c15adadd5be28b49c6277d2f6d178ea12031163746850cdd05deb593b3d6d5d7fb249a4a465')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
build() {
- cd $pkgname
- python2 setup.py build
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
}
package() {
- cd $pkgname
- python2 setup.py install --root="$pkgdir" --optimize=1
+ # binary
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}/target/release/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ # readme
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/README.md" \
+ "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}
-
-# vim:set ts=2 sw=2 et: