summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb9d3039f7f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Vianney le Clément de Saint-Marcq <code AT quartic·eu>
+pkgname=certbot-ovh
+pkgver=0.1
+pkgrel=1
+pkgdesc="OVH DNS Authenticator plugin for Certbot"
+arch=('any')
+url="https://github.com/vianney/certbot-ovh"
+license=('Apache')
+depends=('certbot' 'python-ovh')
+makedepends=('python-setuptools')
+source=("https://github.com/vianney/certbot-ovh/archive/v${pkgver}.tar.gz")
+sha256sums=('37f79e0a7d1462a5b86a2459dbfbc6fc21292434f0f195ddcbe4ba16b619e1de')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}