summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3acd37ee2e98..ee9f968bc4fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,25 @@
pkgname=ch341eepromtool
pkgver=0.5
-pkgrel=2
+pkgrel=3
_git_commit="6b41e07"
pkgdesc="An i2c serial EEPROM programming tool for the WCH CH341A"
arch=('i686' 'x86_64')
url="https://github.com/stefanct/ch341eepromtool"
license=('GPL3')
depends=('libusb>=1')
-source=("git+https://github.com/stefanct/ch341eepromtool.git#commit=${_git_commit}")
-md5sums=('SKIP')
+source=("git+https://github.com/stefanct/ch341eepromtool.git#commit=${_git_commit}"
+ "libusb_set_option.patch"
+ "extern_readbuf.patch")
+md5sums=('SKIP'
+ '9c2db0e0c9e72be4d9d8e6544e75c34b'
+ '5409cb99d67bbe4decab130e4c688c74')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch -p1 --input="${srcdir}/libusb_set_option.patch"
+ patch -p1 --input="${srcdir}/extern_readbuf.patch"
+}
build() {
cd "${srcdir}/${pkgname}"