summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 907c2ad4ffdf..97afd8d569f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
pkgname=check_smartmon-git
-pkgver=r27.71d33af
+pkgver=r43.66ec3f3
pkgrel=1
pkgdesc="Nagios-Plugin that uses smartmontools (http://smartmontools.sourceforge.net/) to check disk health status and temperature."
-arch=('i686' 'x86_64')
-url="https://github.com/nihlaeth/Nagios_check_smartmon"
+arch=('any')
+url="https://github.com/driehuis/Nagios_check_smartmon"
license=('GPL2')
-depends=('python2' 'python2-psutil')
-source=("${pkgname}::git+https://github.com/nihlaeth/Nagios_check_smartmon.git")
+depends=('python-psutil' 'smartmontools')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/driehuis/Nagios_check_smartmon.git")
sha256sums=("SKIP")
pkgver() {
- cd "$pkgname"
+ cd "$pkgname" || exit 1
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$pkgname"
- msg 'Fixing Python version...'
- find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python$#/usr/bin/python2#g'
-}
-
package() {
# Install License
install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"