summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD99
1 files changed, 69 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a68ef376383f..7c7a55eb3619 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,68 @@
-# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
-# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
-
-_pkgbase=cheese
-pkgbase=$_pkgbase-git
-pkgname=($_pkgbase-git lib$_pkgbase-git)
-pkgver=43.alpha+r7+ge2197c0b
-pkgrel=1
+# Maintainer:
+# Contributor: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
+_pkgbase="cheese"
+pkgbase="$_pkgbase-git"
+pkgname=(
+ cheese-git
+ libcheese-git
+)
+pkgver=44.1.r3.ga7af338
+pkgrel=2
pkgdesc="Take photos and videos with your webcam, with fun graphical effects"
-url="https://wiki.gnome.org/Apps/Cheese"
-arch=(x86_64)
-license=(GPL)
-depends=(gtk3 gstreamer gst-plugins-bad gst-plugins-base gst-plugins-good clutter-gst clutter-gtk
- libcanberra librsvg gnome-desktop libgudev dconf gnome-video-effects)
-makedepends=(gobject-introspection vala git appstream-glib meson yelp-tools)
+url="https://gitlab.gnome.org/GNOME/cheese"
+license=('GPL-2.0-or-later')
+arch=('x86_64')
+
+depends=(
+ clutter-gtk
+ gnome-desktop
+ gstreamer
+ gtk3
+ libcanberra
+)
+makedepends=(
+ appstream-glib
+ clutter-gst
+ git
+ gobject-introspection
+ gst-plugins-bad
+ meson
+ vala
+ yelp-tools
+)
checkdepends=(xorg-server-xvfb)
-source=("git+https://gitlab.gnome.org/GNOME/${_pkgbase}.git")
+
+_pkgsrc="$_pkgbase"
+source=("git+https://gitlab.gnome.org/GNOME/cheese.git")
sha256sums=('SKIP')
pkgver() {
- cd "${_pkgbase}"
- git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
+ cd "$_pkgsrc"
+ git describe --long --tags --abbrev=7 \
+ | sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- arch-meson "${_pkgbase}" build -D tests=true
+ local meson_options=(
+ -D tests=true
+ )
+
+ arch-meson "$_pkgsrc" build "${meson_options[@]}"
meson compile -C build
}
check() (
- # glib-compile-schemas "${GSETTINGS_SCHEMA_DIR:=$PWD/cheese/data}"
- # export GSETTINGS_SCHEMA_DIR
+ export GSETTINGS_SCHEMA_DIR="$srcdir/cheese/data"
+ glib-compile-schemas "$GSETTINGS_SCHEMA_DIR"
dbus-run-session xvfb-run -s '-nolisten local' \
meson test -C build --print-errorlogs
)
_pick() {
- local p="$1" f d; shift
+ local p="$1" f d
+ shift
for f; do
d="$srcdir/$p/${f#$pkgdir/}"
mkdir -p "$(dirname "$d")"
@@ -48,9 +73,8 @@ _pick() {
package_cheese-git() {
depends+=("libcheese-git=$pkgver-$pkgrel")
- provides=("${_pkgbase}")
- conflicts=("${_pkgbase}")
- groups=(gnome)
+ provides=("cheese")
+ conflicts=("cheese")
meson install -C build --destdir "$pkgdir"
@@ -63,11 +87,26 @@ package_cheese-git() {
package_libcheese-git() {
pkgdesc="Webcam widget for Clutter and GTK"
- depends=(clutter clutter-gtk clutter-gst gdk-pixbuf2 glib2 gtk3 libcanberra
- gstreamer gst-plugins-base-libs gst-plugins-bad-libs)
- provides=(libcheese.so libcheese-gtk.so libcheese)
+
+ depends=(
+ clutter
+ clutter-gst
+ clutter-gtk
+ dconf
+ gdk-pixbuf2
+ glib2
+ gnome-video-effects
+ gst-plugins-bad-libs
+ gst-plugins-base-libs
+ gstreamer
+ gtk3
+ libcanberra
+ )
+ provides=(
+ libcheese
+ libcheese{,-gtk}.so
+ )
conflicts=(libcheese)
+
mv libs/* "$pkgdir"
}
-
-# vim:set sw=2 et: