summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9fdda3b48e3..29d83a860364 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: bziemons <ben@rs485.network>
pkgname=chr-editor-git
-pkgver=r652.b3a4c07
+pkgver=r932.9c3c094
pkgrel=1
-pkgdesc="Console-based editor designed for simplified use like gedit"
+pkgdesc="Retro-style terminal-based text editor with desktop-like shortcuts utilizing Tui Widgets and integration with KDE's syntax highlighting engine."
arch=("x86_64")
url="https://github.com/istoph/editor"
license=('Boost')
@@ -10,17 +10,22 @@ depends=('tuiwidgets-git' 'qt5-base' 'icu' 'gcc-libs')
makedepends=(meson git)
provides=(chr-editor)
conflicts=(chr-editor)
-options=(strip)
source=("git+https://github.com/istoph/editor.git")
sha512sums=('SKIP')
+# if you want to build chr-editor without syntax highlighting, set CHR_NO_SYNTAX_HIGHLIGHTING to anything
+if [[ "${CHR_NO_SYNTAX_HIGHLIGHTING:+1}" != "1" ]]; then
+ depends=("${depends[@]}" 'syntax-highlighting5')
+ CHR_EXTRA_MESON_ARGS="${CHR_EXTRA_MESON_ARGS:-} -D syntax_highlighting=true"
+fi
+
pkgver() {
cd "editor"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- arch-meson editor _build
+ arch-meson ${CHR_EXTRA_MESON_ARGS:-} editor _build
meson compile -C _build
}