summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08216db57400..35d80f15d3b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Adrián Arroyo Calle <adrian.arroyocalle@gmail.com>
pkgname=ciao-lang
-pkgver=1.22.0.m7
+pkgver=1.23.0.m1
+_pkgver=1.23.0-m1
pkgrel=1
pkgdesc="Ciao is a general purpose, multi-paradigm programming language in the Prolog family"
arch=('i686' 'x86_64')
@@ -9,17 +10,17 @@ url="https://github.com/ciao-lang/ciao"
license=('LGPL-2.1')
depends=('rlwrap')
makedepends=('gcc' 'make' 'which' 'rlwrap')
-source=(https://github.com/ciao-lang/ciao/archive/v1.22.0-m7.tar.gz)
-sha256sums=('b5f75753a558dd9505888862ea831200b16fbe530741d5f1ffd62452d4eec5e2')
+source=(https://github.com/ciao-lang/ciao/archive/v${_pkgver}.tar.gz)
+sha256sums=('ba6318c2d6e994c4dd5e02f4a60b026d7cdd7be8bd472fa0b8665fa439e52d3b')
build() {
- cd "$srcdir/ciao-1.22.0-m7"
+ cd "$srcdir/ciao-$_pkgver"
./ciao-boot.sh configure --prefix="$pkgdir/usr" --instype=global
./ciao-boot.sh build
}
package() {
- cd "$srcdir/ciao-1.22.0-m7"
+ cd "$srcdir/ciao-$_pkgver"
./ciao-boot.sh install
}