summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43c131f1c7c2..a5fcbd350ec1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# https://github.com/orhun/pkgbuilds
pkgname=cicero-git
-pkgver=0.3.0.r0.gcd1af70
+pkgver=0.4.0.r1.gbc292d3
pkgrel=1
pkgdesc="Unicode tool with a terminal user interface (git)"
arch=('x86_64')
url="https://github.com/eyeplum/cicero-tui"
license=('GPL3')
depends=('fontconfig' 'freetype2')
-makedepends=('rust' 'git')
+makedepends=('cargo' 'git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+${url}")
@@ -20,14 +20,19 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${pkgname%-git}-tui"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
build() {
cd "${pkgname%-git}-tui"
- cargo build --release --locked
+ cargo build --release --frozen
}
check() {
cd "${pkgname%-git}-tui"
- cargo test --release --locked
+ cargo test --frozen
}
package() {