summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 18 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a91c92e262b..414926df4ff6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,23 @@
-# Maintainer: Alex Peltzer ("alexpe87") <alexpe.aur@mailbox.org>
-# Co-Maintainer: rosatolen <rosatolen@gmail.com>
-
+# Maintainer: Darren Wu <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
+# Maintainer: Ian Emnace <igemnace@gmail.com>
+# Contributor: rosatolen <rosatolen@gmail.com>
+# Contributor: Alex Peltzer ("alexpe87") <alexpe.aur@mailbox.org>
pkgname=circleci-cli
-pkgver=0.0.4705
+pkgver=0.1.5546
pkgrel=1
-pkgdesc="The circleci commands enable you to reproduce the CircleCI environment locally and run jobs as if they were running on the hosted application"
-arch=('x86_64')
-url="https://github.com/circleci/local-cli"
-license=('MIT')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/circleci/local-cli/archive/v$pkgver-deba4df.tar.gz"
-'https://raw.githubusercontent.com/circleci/local-cli/master/LICENSE')
-
-# CircleCI publishes releases on Amazon AWS according to this documentation:
-# https://circleci.com/docs/2.0/local-cli/#installing-the-circleci-local-cli-on-macos-and-linux-distros
-# They do not provide other means of verifying their download
-md5sums=('SKIP'
-'SKIP')
-
-depends=('docker')
-
-build() {
- mv $srcdir/local-cli-$pkgver-deba4df/circleci.sh circleci
-}
+pkgdesc="Use CircleCI from the command line"
+arch=(x86_64)
+url="https://github.com/CircleCI-Public/circleci-cli"
+license=(MIT)
+depends=(docker)
+source=(
+ "https://github.com/CircleCI-Public/circleci-cli/releases/download/v$pkgver/${pkgname}_${pkgver}_linux_amd64.tar.gz"
+ "https://raw.githubusercontent.com/CircleCI-Public/circleci-cli/v$pkgver/LICENSE"
+)
+sha256sums=('d82ebd29d6c914a280450aa1e434f35db0465c0a02b98d7c0fba2040287cbc1b'
+ '89f336660e1dea7ea005892dc44696fb15544cbffedfbddcd4f6671a735763a9')
package() {
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
- install -Dm755 circleci $pkgdir/usr/bin/circleci
+ install -m 755 -D -t "$pkgdir/usr/bin" "${pkgname}_${pkgver}_linux_amd64/circleci"
+ install -m 644 -D -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}