summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70b73574e692..815678cf5efc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Dewar <a.dewar@sussex.ac.uk>
pkgname=circstat
pkgver=2012a
-pkgrel=2
+pkgrel=3
pkgdesc="The circular statistics toolbox for Matlab/Octave"
arch=("any")
url="http://bethgelab.org/software/circstat"
@@ -14,8 +14,12 @@ package() {
rm "$srcdir"/*.zip
cp -r "$srcdir"/* "$pkgdir"/opt/$pkgname
+ # fix permissions
find "$pkgdir"/opt/$pkgname -type f -exec chmod 644 "{}" \;
+ # fix line endings
+ find "$pkgdir"/opt/$pkgname -type f -not -name '*.mat' -exec sed -i 's/\r//' "{}" \;
+
install -d "$pkgdir"/usr/share/doc/$pkgname
ln -s /opt/$pkgname/readme.txt "$pkgdir"/usr/share/doc/$pkgname