summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01629f13cd0a..556eaaa061ec 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,24 @@
# Contributer: Jeroen Bollen <jbinero at gmail dot comau>
pkgname="ckbcomp-bin"
-pkgver="1.205"
+pkgver=1.210
pkgrel=1
pkgdesc="Compile a XKB keyboard description to a keymap suitable for loadkeys or kbdcontrol"
arch=(any)
url="http://anonscm.debian.org/cgit/d-i/console-setup.git/"
license=('GPL2')
depends=('perl')
+makedepends=('jq' 'curl')
source=("http://ftp.debian.org/debian/pool/main/c/console-setup/console-setup_${pkgver}_all.deb")
sha512sums=('SKIP')
provides=("ckbcomp")
+pkgver(){
+ curl -sL "https://sources.debian.org/api/src/console-setup/" \
+ | jq -r 'select(.package == "console-setup") | .versions[] | select(.suites | index("sid")) | .version' \
+ | head -n 1
+}
+
prepare(){
while read -r pkg; do
dir="${srcdir}/$(basename "${pkg}" | cut -d "." -f 1)"