summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c550b6958981..602c93e2fb88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,17 @@
# <ranaivoarivony-razanajato@hareno.me>
pkgname=clan
-pkgver=0.8.0
+pkgver=0.8.1
pkgrel=1
pkgdesc="Chunky Loop Analyzer: A Polyhedral Representation Extraction Tool for High Level Programs"
arch=(x86_64)
url="http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/index.html"
license=('LGPL')
depends=("osl")
+checkdepends=("valgrind")
provides=("clan")
-source=(http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/docs/${pkgname}-${pkgver}.tar.gz)
-md5sums=('0dcba7f4bdf32159405f27ebce439d63')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # The configure script's '--with-osl=system' option is buggy. The definitions
- # of OSL_LIBS differ depending on the value of '--with-osl' but all of them
- # can be overriden since the script will be called with '--with-osl=system'...
- sed -i 's/OSL_LIBS=.*/OSL_LIBS=" -losl"/' configure
-}
+source=(https://github.com/periscop/clan/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('bffd26cc8b1360e47245ef71cea78aa3')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -30,6 +23,7 @@ build() {
check() {
cd "${srcdir}/${pkgname}-${pkgver}"
make check
+ make valcheck
}
package() {