summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf75b8cc0b03..38f0d60ff07b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=cloak
pkgname=cloak-obfuscation-git
pkgver=v2.2.1.r0.g98a7b73
-pkgrel=1
+pkgrel=2
pkgdesc=' A censorship circumvention tool to evade detection against state adversaries '
arch=('x86_64')
url="https://github.com/cbeuw/Cloak/"
@@ -11,6 +11,7 @@ license=('GPL3')
makedepends=('go')
source=("cloak::git+https://github.com/cbeuw/Cloak.git")
sha256sums=('SKIP')
+backup=('etc/cloak/ckclient.json' 'etc/cloak/ckserver.json')
pkgver() {
cd "$_pkgname"
@@ -33,7 +34,14 @@ build() {
}
package() {
- cd "$_pkgname"/build
+
+ cd "$_pkgname"
+
+ cd build
install -Dm755 ck-server "$pkgdir"/usr/bin/ck-server
install -Dm755 ck-client "$pkgdir"/usr/bin/ck-client
+
+ cd ../example_config
+ install -Dm644 ckclient.json "$pkgdir"/etc/cloak/ckclient.json
+ install -Dm644 ckserver.json "$pkgdir"/etc/cloak/ckserver.json
}