summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD142
1 files changed, 103 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 658c8759ac60..f6c7d655218e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,80 @@
-# Maintainer: Jefferson Gonzalez <jgmdev@gmail.com>
+#
+# AUR PKGBUILD for "bleeding edge" codelite from github repo
+#
+# Maintainer: Uffe Jakobsen <uffe _at_ uffe _dot_ org>
+# Past Maintainer: Jefferson Gonzalez <jgmdev@gmail.com>
# Contributor: Pyro Devil <p dot devil at gmail dot com>
+#
+# NOTES:
+#
+# Using Make as long as Ninja cannot be job-controlled from makepkg.conf (like Make can)
+# Systems with many cores but little memory will be (OOM) killed by Ninja creating too many jobs
+#
pkgname=codelite-git
_gitname=codelite
-pkgver=v12.0.10.r57.g09d91b099
+pkgver=17.7.0.r26.g473b156f7
pkgrel=1
-pkgdesc="A cross platform C/C++/PHP and Node.js IDE written in C++"
-arch=('i686' 'x86_64')
-url="http://www.codelite.org/"
+pkgdesc="Cross platform IDE for C, C++, Rust, Python, PHP and Node.js written in C++"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://codelite.org/"
license=('GPL')
-install=codelite-git.install
-makedepends=('pkgconfig' 'cmake' 'clang')
+
+makedepends=('cmake' 'ninja' 'clang' 'git')
+
depends=(
- 'wxgtk'
- 'libedit'
- 'libssh'
- 'libmariadbclient'
- 'ncurses'
- 'xterm'
- 'curl'
- 'python2'
- 'clang'
- 'lldb'
- 'hunspell'
+ 'wxwidgets-gtk3'
+ 'libedit'
+ 'libssh'
+ 'mariadb-libs'
+ 'ncurses'
+ 'uchardet'
+ 'hunspell'
+ #'ctags'
+ #'xterm'
+ #'wget'
+ #'curl'
+ #'python'
+ #'python2'
)
+
optdepends=(
- 'graphviz: callgraph visualization'
- 'cscope: CScope Integration for CodeLite'
- 'clang: compiler'
- 'gcc: compiler'
- 'gdb: debugger'
- 'valgrind: debugger'
+ 'clang: compiler'
+ 'lldb: debugger'
+ 'gcc: compiler'
+ 'gdb: debugger'
+ 'valgrind: debugger'
+ 'rust: language'
+ 'php: language'
+ 'graphviz: callgraph visualization'
+ 'cscope: CScope Integration for CodeLite'
)
-conflicts=('codelite' 'codelite-bin')
+
provides=('codelite')
+
+conflicts=('codelite')
+
source=(
- git://github.com/eranif/codelite.git
- http://repos.codelite.org/wxCrafterLibs/wxgui.zip
+ ${_gitname}::git+https://github.com/eranif/codelite.git
+ http://repos.codelite.org/wxCrafterLibs/wxgui.zip
)
-md5sums=(
- 'SKIP'
- 'SKIP'
+
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
)
+
noextract=('wxgui.zip')
+#
+#
+#
+
+BUILD_DIR="_build.out"
+
+#
+#
+#
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -51,27 +82,60 @@ pkgver() {
}
prepare() {
+ #cd "${srcdir}"
+ #git clone -b master --single-branch --depth 1 --recursive --shallow-submodules https://github.com/eranif/codelite.git ${_gitname};
+
cd "${srcdir}/${_gitname}"
- mkdir -p build
+
+ git submodule update --init
+ git submodule foreach git submodule update --init
+
+ # Apply patches here:
+ # example: patch -p0 < "${startdir}/codelite-feature.patch"
+
+ #patch -p0 < "${startdir}/codelite-fsw-symlink.patch"
+
+ #patch -p0 < "${startdir}/codelite-DebugAdapterClient-CMakeLists-cxx17.patch"
}
build() {
- cd "${srcdir}/${_gitname}/build"
+ cd "${srcdir}/${_gitname}"
+
+ mkdir -p "${BUILD_DIR}"
CXXFLAGS="${CXXFLAGS} -fno-devirtualize"
+ export CXXFLAGS
+
+ #WX_CONFIG="/usr/bin/wx-config-gtk3"
+ WX_CONFIG="wx-config"
- cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release \
- -DENABLE_CLANG=1 -DENABLE_LLDB=1 -DWITH_MYSQL=1 \
+ # generate
+ # -DWITH_NATIVEBOOK=1 \
+ cmake -G "Unix Makefiles" \
+ -S . \
+ -B "${BUILD_DIR}" \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_LIBDIR=lib \
- ..
+ -DCL_PREFIX=/usr \
+ -DWITH_PCH=0 \
+ -DWITH_WX_CONFIG="${WX_CONFIG}" \
+ -DENABLE_LLDB=1 \
+ -DWITH_MYSQL=0 \
- make
+
+ # build
+ cmake --build "${BUILD_DIR}"
}
package() {
- cd "${srcdir}/${_gitname}/build"
+ cd "${srcdir}/${_gitname}"
+
+ DESTDIR="${pkgdir}" cmake --install "${BUILD_DIR}"
- make -j1 DESTDIR="${pkgdir}" install
- install -m 644 -D "${srcdir}/wxgui.zip" "${pkgdir}/usr/share/codelite/wxgui.zip"
install -m 644 -D "${srcdir}/${_gitname}/LICENSE" "${pkgdir}/usr/share/licenses/codelite/LICENSE"
+ install -m 644 -D "${srcdir}/wxgui.zip" "${pkgdir}/usr/share/codelite/wxgui.zip"
}
+
+#
+# EOF
+#