summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b660d432e39d..90d60cab1752 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
pkgname=conform
-pkgver=0.1.0_alpha.17
-_commit=4eb4beb060332b18c585161728f77aee84b46783
+pkgver=0.1.0_alpha.19
+_commit=b3b6e657fbd4c94f57b81ac95885339ff4ee1b59
pkgrel=1
pkgdesc='Policy enforcement for your pipelines'
arch=('i686' 'x86_64')
url='https://github.com/talos-systems/conform'
license=('MPL2')
depends=('glibc')
-makedepends=('git' 'go-pie')
+makedepends=('git' 'go')
source=("git+https://github.com/talos-systems/conform.git#commit=${_commit}")
sha256sums=('SKIP')
@@ -20,7 +20,9 @@ build() {
SHA="${_commit:0:7}"
TAG="$(git describe --tags --always --dirty)"
go build \
- -ldflags "-extldflags=-Wl,-z,now,-z,relro -s -w -X \"github.com/talos-systems/conform/cmd.Tag=${TAG}\" -X \"github.com/talos-systems/conform/cmd.SHA=${SHA}\" -X \"github.com/talos-systems/conform/cmd.Built=${BUILT}\""
+ -buildmode=pie \
+ -ldflags "-extldflags=${LDFLAGS} -s -w -X \"github.com/talos-systems/conform/cmd.Tag=${TAG}\" -X \"github.com/talos-systems/conform/cmd.SHA=${SHA}\" -X \"github.com/talos-systems/conform/cmd.Built=${BUILT}\"" \
+ -trimpath
}
package() {