summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abd4e4b3e42f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: theguy147 <theguy (aT) mailbox (dOt) org>
+pkgname=crash-git
+pkgver=7.2.9.r16.gfdb41f0
+pkgrel=1
+pkgdesc='Linux kernel crashdump analysis tool. (git version)'
+arch=('x86_64')
+url="https://github.com/crash-utility/crash"
+license=('GPL3')
+conflicts=('crash')
+source=("${pkgname}::git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ CPPFLAGS='' make
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm 755 -t "${pkgdir}/usr/bin" ./crash
+ install -Dm 755 -t "${pkgdir}/usr/share/man/man8" ./crash.8
+}