summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c176e680426
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Elmar <aur@ramle.be>
+_pkgname=crtsh
+pkgname=$_pkgname-git
+pkgver=df40d0a
+pkgrel=1
+
+pkgdesc="This tool shows the result of crt.sh"
+url="https://github.com/famasoon/$_pkgname.git"
+arch=("any")
+license=("none")
+makedepends=("git" "go")
+conflicts=("$_pkgname")
+provides=("$_pkgname=${pkgver}")
+
+source=("git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always
+}
+
+build() {
+ cd $_pkgname
+ go build
+}
+
+package() {
+ install -Dm755 $_pkgname/crtsh -t "${pkgdir}/usr/bin"
+}