summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5806bb61cd3c..5c6fe0c9ef40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Orestis Floros <orestisflo@gmail.com>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Orestis Floros <orestisflo@gmail.com>
pkgname=csmith-git
-pkgver=csmith.2.3.0.r66.gfa77c29
+pkgver=r845.deddca6
pkgrel=1
pkgdesc='A random generator of C programs'
arch=('i686' 'x86_64')
@@ -9,14 +10,13 @@ url='https://github.com/csmith-project/csmith'
license=('BSD')
optdepends=('perl')
makedepends=('git' 'cmake')
-provides=('csmith')
conflicts=('csmith')
-source=('git+git://github.com/csmith-project/csmith')
+source=("git+${url}")
sha1sums=('SKIP')
pkgver() {
- cd csmith
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd csmith
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {