summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e4a83d0b515..724b714f2da6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
# Maintainer: MikoĊ‚aj Baranowski <mikolajb@gmail.com>
pkgname=csvfilter
-pkgver=0.1.r0.g8425b0a
-pkgrel=1
+pkgver=0.1
+pkgrel=2
pkgdesc='Filter for csv files.'
license=('MIT')
arch=('x86_64' 'i686')
url='https://github.com/mikolajb/csvfilter'
depends=()
makedepends=('go')
-source=("${pkgname}::git+https://github.com/mikolajb/csvfilter.git")
-sha256sums=('SKIP')
-
-pkgver() {
- cd ${srcdir}/${pkgname}/
- git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mikolajb/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('faa0f02017b64c8e003a4f356637940033c20f4b26adae802e33f27a078551f1')
build() {
msg2 'Compiling...'
- cd ${srcdir}/${pkgname}/
+ cd ${srcdir}/${pkgname}-${pkgver}/
GOPATH="$GOPATH:$srcdir" go build -o csvfilter
}
package() {
msg2 'Installing...'
- install -Dm755 ${srcdir}/${pkgname}/csvfilter ${pkgdir}/usr/bin/csvfilter
+ install -Dm755 ${srcdir}/${pkgname}-${pkgver}/csvfilter ${pkgdir}/usr/bin/csvfilter
}