summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50ee128ffbd2..42ac83268399 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=csvkit
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc='A suite of utilities for converting to and working with CSV'
arch=(any)
url="https://$pkgname.readthedocs.org"
license=(MIT)
-_pydeps=('agate>=1.6.1'
- 'agate-dbf>=0.2.0'
- 'agate-excel>=0.2.2'
- 'agate-sql>=0.5.3'
+_pydeps=(agate
+ agate-dbf
+ agate-excel
+ agate-sql
six
sphinx_rtd_theme)
depends=(python
@@ -19,14 +19,14 @@ depends=(python
optdepends=('ipython: nicer command-line for csvpy utility')
makedepends=(python-setuptools
python-sphinx)
-checkdepends=(python-pytest)
+checkdepends=(python-pytest
+ python-pytimeparse)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::https://github.com/wireservice/$pkgname/archive/$pkgver.tar.gz")
sha256sums=('ae0d708a5591fc1348b5d1096c7e359c64e0ba8b442eab3121802f62c32f8e4d')
build() {
cd "$_archive"
- export PYTHONHASHSEED=0
python setup.py build
python setup.py build_sphinx
_rtd_theme_path="$(python -c 'import sphinx_rtd_theme; print(sphinx_rtd_theme.get_html_theme_path())')"