summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 43 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec5b207a1fb2..d81e05d37307 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,62 @@
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
-pkgname=d-feet-git
-pkgver=0.3.16.r1.g7874512
+_pkgname=d-feet
+pkgname="${_pkgname}-git"
+pkgver=0.3.16.r15.g4f00ee6
pkgrel=1
pkgdesc="D-Bus debugger for GNOME"
arch=('any')
-url="https://gitlab.gnome.org/GNOME/d-feet"
+url="https://gitlab.gnome.org/GNOME/${_pkgname}"
license=('GPL2')
-depends=('gtk3' 'glib2' 'python-gobject' 'python>=2.7')
-makedepends=('meson' 'gobject-introspection')
+depends=(
+ gtk3
+ python-gobject
+)
+makedepends=(
+ gobject-introspection
+ meson
+ python-pycodestyle
+ yelp-tools
+)
checkdepends=('xorg-server-xvfb')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=(git+$url.git)
-sha256sums=('SKIP')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=(
+ "git+${url}.git"
+ meson-drop-unused-argument.patch
+)
+sha512sums=(
+ 'SKIP'
+ '019dbeff67c22eccab4e34ed3c3aa292a86c6113f0f9575ecbec948aa5e2fc06f0f862d8e07d8ce566045e6aeb985cebddbc3c70ce6cffc8a074c1e08c80e27c'
+)
pkgver() {
- cd "${pkgname%-git}"
+ cd "${_pkgname}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long 2>/dev/null \
+ | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
)
}
+prepare() {
+ cd "${_pkgname}"
+ patch -Np1 -i ${srcdir}/meson-drop-unused-argument.patch
+}
+
build() {
- arch-meson "${pkgname%-git}" build
+ arch-meson "${_pkgname}" build
meson compile -C build
}
+check() {
+ xvfb-run meson test -C build --print-errorlogs
+}
+
package() {
- DESTDIR="$pkgdir" meson install -C build
- python -m compileall -d /usr/lib "$pkgdir/usr/lib"
- python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
+ meson install -C build --destdir "${pkgdir}"
+ python -m compileall -d /usr/lib "${pkgdir}/usr/lib"
+ python -O -m compileall -d /usr/lib "${pkgdir}/usr/lib"
}