summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c70bdf22772..524bded395fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,36 @@
-# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
# Contributor: John Beard <john.j.beard@gmail.com>
# shellcheck disable=SC2034
_pkgname=daty
-pkgname=$_pkgname-git
+pkgname="${_pkgname}-git"
pkgver=1.0beta+81+g1a5dce4
-pkgrel=1
+pkgrel=2
pkgdesc='Daty Wikidata Editor'
-url='https://gitlab.gnome.org/World/daty'
+url="https://gitlab.gnome.org/World/${_pkgname}"
license=('AGPLv3')
arch=('x86_64')
-depends=('libhandy0' 'python-appdirs' 'python-bleach' 'python-beautifulsoup4' 'python-gobject' 'python-requests' 'python-setproctitle' 'python-pywikibot')
-makedepends=('git' 'python-setuptools')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=("$_pkgname::git+$url.git")
+depends=(
+ 'libhandy0'
+ 'python-appdirs'
+ 'python-bleach'
+ 'python-beautifulsoup4'
+ 'python-gobject'
+ 'python-requests'
+ 'python-setproctitle'
+ 'python-pywikibot'
+)
+makedepends=(
+ 'git'
+ 'python-setuptools'
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}