summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e97add4ff51..fcc4ee83caaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Contributor: Jozef Riha <jose1711 at gmail dot com>
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
pkgname=deadspace
pkgver=1
-pkgrel=3
+pkgrel=4
pkgdesc="a utility that prohibits mouse from entering dead space when screen spans over multiple monitors"
url="http://www.abclinuxu.cz/blog/Joseho_blog/2009/9/najde-sa-niekto-na-napisanie-patchu"
license=("custom:beerware")
@@ -12,9 +12,13 @@ source=("http://eeg.cz/=forro=/dead_space.tar.gz" "new_xorg.patch")
md5sums=('bf60dd4bb85b834ca701705f0b30f553'
'ea73283dba6472683d79c8c8281fd4f6')
-build() {
+package() {
cd dead_space
patch < ../new_xorg.patch dead_space.c
- make || return 1
+ make
+}
+
+package() {
+ cd dead_space
install -D -m755 dead_space ${pkgdir}/usr/bin/dead_space
}