summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df633c01916c..a68ebf5f2532 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Arnaud Dovi <mr.dovi@gmail.com>
pkgname=detect-it-easy-git
-pkgver=3.06
+pkgver=3.10
pkgrel=1
pkgdesc='Detect It Easy, or abbreviated "DIE" is a program for determining types of files'
arch=('x86_64')
@@ -44,6 +44,11 @@ _color="\e[33m"
_bold='\e[1m'
_prefix=" ${_bold}${_color}==>${_stop} "
+pkgver() {
+ cd "$_srcname" || return
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
prepare() {
cd "$srcdir/$_srcname"
git submodule update --init --recursive
@@ -89,7 +94,7 @@ package() {
echo -e "${_prefix}Copying the package files"
install -Dm 644 gui_source/translation/* -t "$pkgdir"/opt/"${_pkgname}"/lang
install -Dm 644 XStyles/qss/* -t "$pkgdir"/opt/"${_pkgname}"/qss
- install -Dm 644 Detect-It-Easy/info/* -t "$pkgdir"/opt/"${_pkgname}"/info
+ cp -r XInfoDB/info/* -t "$pkgdir"/opt/"${_pkgname}"/info/
cp -r Detect-It-Easy/db/* -t "$pkgdir"/opt/"${_pkgname}"/db/
install -Dm 644 signatures/crypto.db -t "$pkgdir"/opt/"${_pkgname}"/signatures
cp -r images/* -t "$pkgdir"/opt/"${_pkgname}"/images/