summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 33 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14070e1a58b5..084d823a386b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,40 @@
-# Maintainer: Uzerus < szymonscholz at gmail.com >
-# Contributor: Justin Dray <justin@dray.be>
-# Contributor: Augusto F. Hack <hack.augusto@gmail.com>
+# Maintainer: Bipin Kumar <kbipinkumar@pm.me>
+# shellcheck disable=2034
+# shellcheck disable=2148
pkgname=diamond
-pkgver=4.0.515
-pkgrel=3
-pkgdesc="Daemon that collects system metrics and publishes
-them to graphite and others"
-arch=('any')
-url="https://github.com/python-diamond/Diamond"
-license=('mit')
-depends=('python2' 'python')
-makedepends=('')
-optdepends=('python2-psycopg2: Postgresql collector'
- 'python2-pysensors: LMSensors collector'
- 'libvirt-python: LibvirtKVM collector'
- 'python2-yaml: PuppetAgent collector')
-backup=(etc/diamond/diamond.conf)
-source=("https://pypi.python.org/packages/0c/b6/4c58a8a1111c138fbed9e65dd918be706af8abd07bb5e8fe3ddfb453d899/${pkgname}-${pkgver}.tar.gz"
- "https://archive.org/download/${pkgname}_201801/${pkgname}.service")
-md5sums=('9ef6c5203e098da10aa0d90b344a49da'
- '4294f34a8a4644c28788b997dcb4ba22')
+pkgver=2.1.9
+pkgrel=1
+pkgdesc="High performance sequence aligner for protein and translated DNA searches with big sequence data. https://doi.org/10.1038/s41592-021-01101-x"
+arch=('x86_64')
+url="https://github.com/bbuchfink/diamond"
+license=('GPL3')
+depends=('gcc-libs' 'zlib' 'zstd' 'blast+' 'glibc')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bbuchfink/diamond/archive/v$pkgver.tar.gz")
+sha256sums=('4cde9df78c63e8aef9df1e3265cd06a93ce1b047d6dba513a1437719b70e9d88')
+build() {
+ cd $pkgname-$pkgver
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DWITH_ZSTD=ON \
+ -DBLAST_INCLUDE_DIR=/usr/include/ncbi-tools++ \
+ -DBLAST_LIBRARY_DIR=/usr/lib/ \
+ -DZSTD_LIBRARY=/usr/lib/libzstd.so \
+ -DZLIB_INCLUDE_DIR=/usr/include \
+ -Wno-dev
-package() {
- cd "$srcdir/diamond-${pkgver}"
-
- install -D -m644 "$srcdir/diamond.service" "$pkgdir/usr/lib/systemd/system/diamond.service"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- rm "$pkgdir/etc/diamond/diamond.conf.example.windows"
- rm -rf "$pkgdir/etc/diamond/collectors"
- rm -rf "$pkgdir/etc/diamond/handlers"
- rm -rf "$pkgdir/usr/share/diamond/user_scripts"
- mv "$pkgdir/etc/diamond/diamond.conf.example" "$pkgdir/etc/diamond/diamond.conf"
+ cmake --build build
+}
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+check() {
+ cd $pkgname-$pkgver
+ ctest --test-dir build --output-on-failure
}
+package() {
+ cd $pkgname-$pkgver
+ DESTDIR="$pkgdir" cmake --install build
+}