summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f3115e82b98..ae6752c1fd0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Bjoern Franke <bjo@nord-west.org>
+# Maintainer: Thomas Haider <t.haider@deprecate.de>
+# Contributor: Bjoern Franke <bjo@nord-west.org>
pkgbase=dnssec-reverb-git
pkgname=dnssec-reverb
-pkgver=r13.376067d
+pkgver=r30.9aa8e24
pkgrel=1
pkgdesc="Shell script based DNSSEC key management tool"
arch=('any')
@@ -10,14 +11,25 @@ url="https://github.com/northox/dnssec-reverb"
license=('Simplified BSD')
optdepends=('dnssec-tools: DNSSEC tools for BIND'
'ldns: tools for NSD')
-source=("${pkgname}::git+https://github.com/northox/${pkgname}.git")
-md5sums=('SKIP')
+makedepends=('git')
+backup=('etc/dnssec-reverb.conf' 'etc/dnssec-reverb.conf-bind')
+source=("${pkgname}::git+https://github.com/northox/${pkgname}.git"
+ "dateformat.patch"
+ "rootcheck.patch")
+md5sums=('SKIP'
+ '8d7cb4088b45171ec9c3b64f95785464'
+ '172c4bc58fce6706259ace9b9d068e8f')
pkgver() {
cd "${srcdir}/${pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "${srcdir}/${pkgname-git}"
+ git apply ${srcdir}/dateformat.patch
+ git apply ${srcdir}/rootcheck.patch
+}
package() {
cd "${srcdir}/${pkgname}"