summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 18 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5a6c76f793d..870f2f6d1f96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=dolphin-emu-faster-melee
# shellcheck disable=SC2034
pkgver=4.4
# shellcheck disable=SC2034
-pkgrel=2
+pkgrel=3
# shellcheck disable=SC2034
pkgdesc='The FasterMelee NetPlay build of the Dolphin Emulator'
# shellcheck disable=SC2034
@@ -33,6 +33,7 @@ options=('!emptydirs')
# The commit for FasterMelee 4.3 (unchanged for FasterMelee 4.4)
# shellcheck disable=SC2034
source=("${pkgname}::git+https://github.com/Tinob/Ishiiruka.git#commit=0b00f1f6267190a8bf9a3584497a35d8762eb0a9"
+ "0001-Fix-RasterFont.cpp-compile-error.patch"
"GALE01r2.ini"
"GALE01.ini"
"MNCE02.ini"
@@ -41,6 +42,7 @@ source=("${pkgname}::git+https://github.com/Tinob/Ishiiruka.git#commit=0b00f1f62
)
# shellcheck disable=SC2034
sha256sums=('SKIP'
+ '7a512b04f1d067e7ba59f4b0c7b3720018eccfd6bb63cd5c47ac84ee82b3ccfa'
'eae12be9d008453d09bf1379315a2299eca9c76cc093727f8f41926193981c50'
'a930e0490bfa95f66f96919d320e04f99d6988587209700a536bf7549d53466a'
'4dd62a40be7a41c92079c9ee23f5fd458c85f275431881c707450f634fdcf24c'
@@ -49,6 +51,21 @@ sha256sums=('SKIP'
# shellcheck disable=SC2034
provides=('dolphin-emu')
+# Pulled directly from github.com/ccl2of4
+# Thank you
+prepare() {
+ # shellcheck disable=SC2154
+ cd "${srcdir}/${pkgname}" || {
+ msg "Failed to cd into ${srcdir}/${pkgname}"
+ return 1
+ }
+
+ patch -p1 < ../0001-Fix-RasterFont.cpp-compile-error.patch || {
+ msg "Failed to apply patch file"
+ return 1
+ }
+}
+
build() {
# shellcheck disable=SC2154
cd "${srcdir}/${pkgname}" || {