summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD158
1 files changed, 114 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 619461446488..9f63e3326e2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,72 +1,142 @@
# Maintainer: Florian Maunier <fmauneko@dissidence.ovh>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Max Liebkies <mail@maxliebkies.de>
+# Contributor: Attila Greguss <floyd0122[at]gmail[dot]com>
pkgbase=dotnet-core-preview
-pkgname=('dotnet-host-preview' 'dotnet-runtime-preview' 'aspnet-runtime-preview' 'dotnet-sdk-preview')
-pkgver=3.0.0+100+preview.013656
-pkgrel=1
-arch=('x86_64')
-url='https://www.microsoft.com/net/core'
-license=('MIT')
-makedepends=(
- 'clang' 'cmake' 'curl' 'git' 'icu' 'krb5' 'libunwind' 'lldb' 'llvm'
- 'lttng-ust' 'openssl' 'zlib'
-)
-options=('staticlibs')
-source=(
- 'https://download.visualstudio.microsoft.com/download/pr/a0e368ac-7161-4bde-a139-1a3ef5a82bbe/439cdbb58950916d3718771c5d986c35/dotnet-sdk-3.0.100-preview8-013656-linux-x64.tar.gz'
- 'https://download.visualstudio.microsoft.com/download/pr/0bff102b-7983-4947-be67-be740e168ec1/d4b2a3818f2849501710b6ee16a1e2be/aspnetcore-runtime-3.0.0-preview8.19405.7-linux-x64.tar.gz'
- 'dotnet.sh'
+pkgname=(
+ dotnet-host-preview
+ aspnet-runtime-preview
+ dotnet-runtime-preview
+ dotnet-sdk-preview
+ # netstandard-targeting-pack-preview
+ dotnet-targeting-pack-preview
+ aspnet-targeting-pack-preview
)
-sha256sums=('6ce2353764f57a8721fb4caa43851c826913ad3bd24640caeb5503432bd45ca8'
- '50e81dab852bdf0d95ae6d5fe39860dff676282cd2fe4e3824d76230117be3eb'
- 'f4cb02490234b853946477f82514f0c6247b55b08b2e85fae98e99a6e6974edd')
+pkgver=6.0.0.sdk100+rc.1.21463.6
+_hostver=6.0.0-rc.1.21451.13
+_dotnetruntimever=6.0.0-rc.1.21451.13
+_aspnetruntimever=6.0.0-rc.1.21452.15
+_sdkver=6.0.100-rc.1.21463.6
+pkgrel=1
+arch=(x86_64 armv7h aarch64)
+url=https://www.microsoft.com/net/core
+license=(MIT)
+options=(staticlibs)
+source=(dotnet.sh
+ register-completions.bash
+ register-completions.fish
+ register-completions.zsh)
+source_x86_64=(https://download.visualstudio.microsoft.com/download/pr/5fcb98bb-21e1-47a5-bb8e-bb25f41a3e52/04811d5d05b7e694f040d2a13c1aae4c/dotnet-sdk-6.0.100-rc.1.21463.6-linux-x64.tar.gz)
+source_armv7h=(https://download.visualstudio.microsoft.com/download/pr/a31e2042-c0fb-47e1-a1a6-9e925bf33182/1479d388ef3ece7e1048a9423486b821/dotnet-sdk-6.0.100-rc.1.21463.6-linux-arm.tar.gz)
+source_aarch64=(https://download.visualstudio.microsoft.com/download/pr/c56c49ce-176e-4472-bd0c-5667475790f2/018c2de72f984826afe4b1b87715f1c0/dotnet-sdk-6.0.100-rc.1.21463.6-linux-arm64.tar.gz)
+sha512sums=('e61b9e3e5a2305646a616d598378230c9755c5dd5363692cc363f8f4add3807563c324dd86f3a7ae9d358c82d730608e7b293935a2b6c81c0c0f62d752a0a1cf'
+ '9f977e0bd12abc0dda4d914f369c58fce502b4030cf91d4248b32242d98fe5a2bbd8446502feeb914561f310dfd3c113bb6da19bfd5dfa6233109e62d22fa966'
+ '1de3f09b96c44429b026277bb135a019b7577df2dec5f695ce51d18daefe2c1736b3359ab95f2abc46f7320c445b968e5582df92bb2bcad3ac5cfc5a32d3c5b6'
+ 'f2be62d9cce00357b7b18ae83b976841037830b7b9ed1b67445f76e02550c904be5ab023366441199f9bb3dfd602004b0334395ffdde6c313910c1da5c39c4a3')
+sha512sums_x86_64=('a1d1de7950d0a7221abc4aa73221a5e7f5093a7aa2142ffb89691c3c1ff605c84574ff9375f83d3f16848b90245bc941f66b3d4b22ce6a4c9845f21bd1eb868e')
+sha512sums_armv7h=('8461399292a7dedcbd31295bc6b3e010b0ac0b69dc742026bdfe795780543b9458a3df343d83528d5a0eb60b774ef535aea4f8d3061bf151d7dc90adccf1ad54')
+sha512sums_aarch64=('d1ebb53cd36617a3e02dbb759a842d2f62ba70b71b528c31e7c76d5137b655865c570c8ad50a0f206264db836afe83e3fb42037bf80127d179cecb8f7b3f28e7')
package_dotnet-host-preview() {
- pkgdesc='A generic driver for the .NET Core Command Line Interface (preview)'
- provides=('dotnet-host')
- conflicts=('dotnet-host')
+ pkgdesc='A generic driver for the .NET Core Command Line Interface (preview, binary)'
+ depends=(glibc)
+ provides=(dotnet-host dotnet-host=${_hostver%-*})
+ conflicts=(dotnet-host)
- install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses/dotnet-host-preview}
- cp -dr --no-preserve='ownership' dotnet host "${pkgdir}"/opt/dotnet/
+ install -dm 755 "${pkgdir}"/usr/{bin,lib,share/{dotnet,licenses/dotnet-host-preview}}
+ cp -dr --no-preserve='ownership' dotnet host "${pkgdir}"/usr/share/dotnet/
cp -dr --no-preserve='ownership' LICENSE.txt ThirdPartyNotices.txt "${pkgdir}"/usr/share/licenses/dotnet-host-preview
- install -Dm 755 "${srcdir}"/dotnet.sh "${pkgdir}"/usr/bin/dotnet
+ ln -sf /usr/share/dotnet/dotnet "${pkgdir}"/usr/bin/dotnet
+ ln -sf /usr/share/dotnet/host/fxr/"${_hostver}"/libhostfxr.so "${pkgdir}"/usr/lib/libhostfxr.so
+ install -Dm 644 "${srcdir}"/dotnet.sh -t "${pkgdir}"/etc/profile.d/
+ install -Dm 644 "${srcdir}"/register-completions.bash "${pkgdir}"/usr/share/bash-completion/completions/dotnet
+ install -Dm 644 "${srcdir}"/register-completions.fish "${pkgdir}"/usr/share/fish/vendor_completions.d/dotnet.fish
+ install -Dm 644 "${srcdir}"/register-completions.zsh "${pkgdir}"/usr/share/zsh/site-functions/_dotnet
}
package_dotnet-runtime-preview() {
- pkgdesc='The .NET Core runtime (preview)'
- depends=('dotnet-host-preview' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
- 'libcurl.so')
+ pkgdesc='The .NET Core runtime (preview, binary)'
+ depends=(
+ "dotnet-host>=${_hostver%-*}"
+ glibc
+ icu
+ krb5
+ libcurl.so
+ libunwind
+ openssl
+ zlib
+ )
+
optdepends=('lttng-ust: CoreCLR tracing')
- provides=('dotnet-runtime-3.0')
- conflicts=('dotnet-runtime-3.0')
+ provides=(dotnet-runtime=${_dotnetruntimever%-*} dotnet-runtime-6.0)
+ conflicts=(dotnet-runtime=${_dotnetruntimever%-*})
- install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
- cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/opt/dotnet/shared/
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
ln -s dotnet-host-preview "${pkgdir}"/usr/share/licenses/dotnet-runtime-preview
}
package_aspnet-runtime-preview() {
- pkgdesc='The ASP.NET Core runtime (preview)'
- depends=('dotnet-runtime-preview')
- provides=('aspnet-runtime-3.0')
- conflicts=('aspnet-runtime-3.0')
+ pkgdesc='The ASP.NET Core runtime (preview, binary)'
+ depends=(dotnet-runtime-preview)
+ provides=(aspnet-runtime=${_aspnetruntimever%-*} aspnet-runtime-6.0)
+ conflicts=(aspnet-runtime=${_aspnetruntimever%-*})
- install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
- cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
ln -s dotnet-host-preview "${pkgdir}"/usr/share/licenses/aspnet-runtime-preview
}
package_dotnet-sdk-preview() {
- pkgdesc='The .NET Core SDK (preview)'
- depends=('dotnet-runtime-preview')
- provides=('dotnet-sdk-3.0')
- conflicts=('dotnet-sdk-3.0')
+ pkgdesc='The .NET Core SDK (preview, binary)'
+ depends=(
+ dotnet-runtime-preview
+ dotnet-targeting-pack-preview
+ glibc
+ netstandard-targeting-pack-2.1
+ )
+ optdepends=('aspnet-targeting-pack-preview: Build ASP.NET Core applications')
+ provides=(dotnet-sdk=${_sdkver%-*} dotnet-sdk-6.0)
+ conflicts=(dotnet-sdk=${_sdkver%-*})
- install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses}
- cp -dr --no-preserve='ownership' sdk "${pkgdir}"/opt/dotnet/
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
+ cp -dr --no-preserve='ownership' sdk sdk-manifests templates "${pkgdir}"/usr/share/dotnet/
ln -s dotnet-host-preview "${pkgdir}"/usr/share/licenses/dotnet-sdk-preview
}
-# vim: ts=2 sw=2 et:
+# package_netstandard-targeting-pack-preview() {
+# pkgdesc='The .NET Standard targeting pack (preview, binary)'
+# provides=(netstandard-targeting-pack-2.1)
+# conflicts=(netstandard-targeting-pack-2.1)
+
+# install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
+# cp -dr --no-preserve='ownership' packs/NETStandard.Library.Ref "${pkgdir}"/usr/share/dotnet/packs/
+# ln -s dotnet-host "${pkgdir}"/usr/share/licenses/netstandard-targeting-pack-preview
+# }
+
+package_dotnet-targeting-pack-preview() {
+ pkgdesc='The .NET Core targeting pack (preview, binary)'
+ depends=(netstandard-targeting-pack-2.1)
+ provides=(dotnet-targeting-pack=${_dotnetruntimever%-*} dotnet-targeting-pack-6.0)
+ conflicts=(dotnet-targeting-pack=${_dotnetruntimever%-*})
+
+ if [ $CARCH = 'x86_64' ]; then msarch=x64;
+ elif [ $CARCH = 'armv7h' ]; then msarch=arm;
+ elif [ $CARCH = 'aarch64' ]; then msarch=arm64; fi
+
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
+ cp -dr --no-preserve='ownership' packs/Microsoft.NETCore.App.{Host.linux-${msarch},Ref} "${pkgdir}"/usr/share/dotnet/packs/
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-targeting-pack-preview
+}
+
+package_aspnet-targeting-pack-preview() {
+ pkgdesc='The ASP.NET Core targeting pack (preview, binary)'
+ depends=(dotnet-targeting-pack-preview)
+ provides=(aspnet-targeting-pack=${_aspnetruntimever%-*} aspnet-targeting-pack-6.0)
+ conflicts=(aspnet-targeting-pack=${_aspnetruntimever%-*})
+
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
+ cp -dr --no-preserve='ownership' packs/Microsoft.AspNetCore.App.Ref "${pkgdir}"/usr/share/dotnet/packs/
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/aspnet-targeting-pack-preview
+}