summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 40 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f227287239f..9f63e3326e2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,21 +13,30 @@ pkgname=(
dotnet-targeting-pack-preview
aspnet-targeting-pack-preview
)
-pkgver=5.0.0+100+rc.2.20479.15
-_hostver=5.0.0-rc.2.20475.5
-_runtimever=5.0.0-rc.2.20475.5
-_sdkver=5.0.100-rc.2.20479.15
+pkgver=6.0.0.sdk100+rc.1.21463.6
+_hostver=6.0.0-rc.1.21451.13
+_dotnetruntimever=6.0.0-rc.1.21451.13
+_aspnetruntimever=6.0.0-rc.1.21452.15
+_sdkver=6.0.100-rc.1.21463.6
pkgrel=1
arch=(x86_64 armv7h aarch64)
url=https://www.microsoft.com/net/core
license=(MIT)
options=(staticlibs)
-source_x86_64=(https://download.visualstudio.microsoft.com/download/pr/69cb8922-7bb0-4d3a-aa92-8cb885fdd0a6/2fd4da9e026f661caf8db9c1602e7b2f/dotnet-sdk-5.0.100-rc.2.20479.15-linux-x64.tar.gz)
-source_armv7h=(https://download.visualstudio.microsoft.com/download/pr/068ebc6e-4a1d-45ec-a766-733a142f2839/e0da4c731c943ca2b267c15edb565108/dotnet-sdk-5.0.100-rc.2.20479.15-linux-arm.tar.gz)
-source_aarch64=(https://download.visualstudio.microsoft.com/download/pr/b416bc12-1478-4241-bc31-6fe68f8b73b6/582f018a97172f4975973390cf3f58e7/dotnet-sdk-5.0.100-rc.2.20479.15-linux-arm64.tar.gz)
-sha512sums_x86_64=(e705043cdec53827695567eed021c76b100d77416f10cc18d4f5d02950f85bf9ccd7e2c22643f00a883e11b253fb8aa098e4dce008008a0796f913496f97e362)
-sha512sums_armv7h=(22e97c15393a4f986563f5e8b031b49983eb55531170b86594d7caab819b41032393a9b3db4ee96cb88fae3971ba243bb64187606e3a00fc64d2e434d906a637)
-sha512sums_aarch64=(1aab49b2c328c4de8c40e790df99aa327a3aeba5d904696fa151acbfb7b5620ebf3d1e2e9726895d92b6146295840ffe3f2fb7208a81c7b73d2c92c9fcf50dbf)
+source=(dotnet.sh
+ register-completions.bash
+ register-completions.fish
+ register-completions.zsh)
+source_x86_64=(https://download.visualstudio.microsoft.com/download/pr/5fcb98bb-21e1-47a5-bb8e-bb25f41a3e52/04811d5d05b7e694f040d2a13c1aae4c/dotnet-sdk-6.0.100-rc.1.21463.6-linux-x64.tar.gz)
+source_armv7h=(https://download.visualstudio.microsoft.com/download/pr/a31e2042-c0fb-47e1-a1a6-9e925bf33182/1479d388ef3ece7e1048a9423486b821/dotnet-sdk-6.0.100-rc.1.21463.6-linux-arm.tar.gz)
+source_aarch64=(https://download.visualstudio.microsoft.com/download/pr/c56c49ce-176e-4472-bd0c-5667475790f2/018c2de72f984826afe4b1b87715f1c0/dotnet-sdk-6.0.100-rc.1.21463.6-linux-arm64.tar.gz)
+sha512sums=('e61b9e3e5a2305646a616d598378230c9755c5dd5363692cc363f8f4add3807563c324dd86f3a7ae9d358c82d730608e7b293935a2b6c81c0c0f62d752a0a1cf'
+ '9f977e0bd12abc0dda4d914f369c58fce502b4030cf91d4248b32242d98fe5a2bbd8446502feeb914561f310dfd3c113bb6da19bfd5dfa6233109e62d22fa966'
+ '1de3f09b96c44429b026277bb135a019b7577df2dec5f695ce51d18daefe2c1736b3359ab95f2abc46f7320c445b968e5582df92bb2bcad3ac5cfc5a32d3c5b6'
+ 'f2be62d9cce00357b7b18ae83b976841037830b7b9ed1b67445f76e02550c904be5ab023366441199f9bb3dfd602004b0334395ffdde6c313910c1da5c39c4a3')
+sha512sums_x86_64=('a1d1de7950d0a7221abc4aa73221a5e7f5093a7aa2142ffb89691c3c1ff605c84574ff9375f83d3f16848b90245bc941f66b3d4b22ce6a4c9845f21bd1eb868e')
+sha512sums_armv7h=('8461399292a7dedcbd31295bc6b3e010b0ac0b69dc742026bdfe795780543b9458a3df343d83528d5a0eb60b774ef535aea4f8d3061bf151d7dc90adccf1ad54')
+sha512sums_aarch64=('d1ebb53cd36617a3e02dbb759a842d2f62ba70b71b528c31e7c76d5137b655865c570c8ad50a0f206264db836afe83e3fb42037bf80127d179cecb8f7b3f28e7')
package_dotnet-host-preview() {
pkgdesc='A generic driver for the .NET Core Command Line Interface (preview, binary)'
@@ -40,6 +49,10 @@ package_dotnet-host-preview() {
cp -dr --no-preserve='ownership' LICENSE.txt ThirdPartyNotices.txt "${pkgdir}"/usr/share/licenses/dotnet-host-preview
ln -sf /usr/share/dotnet/dotnet "${pkgdir}"/usr/bin/dotnet
ln -sf /usr/share/dotnet/host/fxr/"${_hostver}"/libhostfxr.so "${pkgdir}"/usr/lib/libhostfxr.so
+ install -Dm 644 "${srcdir}"/dotnet.sh -t "${pkgdir}"/etc/profile.d/
+ install -Dm 644 "${srcdir}"/register-completions.bash "${pkgdir}"/usr/share/bash-completion/completions/dotnet
+ install -Dm 644 "${srcdir}"/register-completions.fish "${pkgdir}"/usr/share/fish/vendor_completions.d/dotnet.fish
+ install -Dm 644 "${srcdir}"/register-completions.zsh "${pkgdir}"/usr/share/zsh/site-functions/_dotnet
}
package_dotnet-runtime-preview() {
@@ -56,8 +69,8 @@ package_dotnet-runtime-preview() {
)
optdepends=('lttng-ust: CoreCLR tracing')
- provides=(dotnet-runtime=${_runtimever%-*} dotnet-runtime-5.0)
- conflicts=(dotnet-runtime=${_runtimever%-*})
+ provides=(dotnet-runtime=${_dotnetruntimever%-*} dotnet-runtime-6.0)
+ conflicts=(dotnet-runtime=${_dotnetruntimever%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -67,8 +80,8 @@ package_dotnet-runtime-preview() {
package_aspnet-runtime-preview() {
pkgdesc='The ASP.NET Core runtime (preview, binary)'
depends=(dotnet-runtime-preview)
- provides=(aspnet-runtime=${_runtimever%-*} aspnet-runtime-5.0)
- conflicts=(aspnet-runtime=${_runtimever%-*})
+ provides=(aspnet-runtime=${_aspnetruntimever%-*} aspnet-runtime-6.0)
+ conflicts=(aspnet-runtime=${_aspnetruntimever%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -81,14 +94,14 @@ package_dotnet-sdk-preview() {
dotnet-runtime-preview
dotnet-targeting-pack-preview
glibc
- netstandard-targeting-pack
+ netstandard-targeting-pack-2.1
)
optdepends=('aspnet-targeting-pack-preview: Build ASP.NET Core applications')
- provides=(dotnet-sdk=${_sdkver%-*} dotnet-sdk-5.0)
+ provides=(dotnet-sdk=${_sdkver%-*} dotnet-sdk-6.0)
conflicts=(dotnet-sdk=${_sdkver%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
- cp -dr --no-preserve='ownership' sdk templates "${pkgdir}"/usr/share/dotnet/
+ cp -dr --no-preserve='ownership' sdk sdk-manifests templates "${pkgdir}"/usr/share/dotnet/
ln -s dotnet-host-preview "${pkgdir}"/usr/share/licenses/dotnet-sdk-preview
}
@@ -104,20 +117,24 @@ package_dotnet-sdk-preview() {
package_dotnet-targeting-pack-preview() {
pkgdesc='The .NET Core targeting pack (preview, binary)'
- depends=(netstandard-targeting-pack)
- provides=(dotnet-targeting-pack=${_runtimever%-*} dotnet-targeting-pack-5.0)
- conflicts=(dotnet-targeting-pack=${_runtimever%-*})
+ depends=(netstandard-targeting-pack-2.1)
+ provides=(dotnet-targeting-pack=${_dotnetruntimever%-*} dotnet-targeting-pack-6.0)
+ conflicts=(dotnet-targeting-pack=${_dotnetruntimever%-*})
+
+ if [ $CARCH = 'x86_64' ]; then msarch=x64;
+ elif [ $CARCH = 'armv7h' ]; then msarch=arm;
+ elif [ $CARCH = 'aarch64' ]; then msarch=arm64; fi
install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
- cp -dr --no-preserve='ownership' packs/Microsoft.NETCore.App.{Host.linux-x64,Ref} "${pkgdir}"/usr/share/dotnet/packs/
+ cp -dr --no-preserve='ownership' packs/Microsoft.NETCore.App.{Host.linux-${msarch},Ref} "${pkgdir}"/usr/share/dotnet/packs/
ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-targeting-pack-preview
}
package_aspnet-targeting-pack-preview() {
pkgdesc='The ASP.NET Core targeting pack (preview, binary)'
depends=(dotnet-targeting-pack-preview)
- provides=(aspnet-targeting-pack=${_runtimever%-*} aspnet-targeting-pack-5.0)
- conflicts=(aspnet-targeting-pack=${_runtimever%-*})
+ provides=(aspnet-targeting-pack=${_aspnetruntimever%-*} aspnet-targeting-pack-6.0)
+ conflicts=(aspnet-targeting-pack=${_aspnetruntimever%-*})
install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
cp -dr --no-preserve='ownership' packs/Microsoft.AspNetCore.App.Ref "${pkgdir}"/usr/share/dotnet/packs/