summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3073d7c5890..6ac16e623e8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Ulises Jeremias Cornejo Fandos <ulisescf.24@gmail.com>
pkgname=dots-stable
-pkgver=1.2.4
+pkgver=1.3.1
pkgrel=1
pkgdesc="Dotfiles generator that allows quick configuration and managing of different tools and window managers in multiple OSs"
arch=(any)
url="https://github.com/ulises-jeremias/dotfiles"
license=('MIT')
-depends=(git)
+depends=(git chezmoi)
optdepends=()
provides=(dots)
conflicts=(dots)
@@ -15,17 +15,20 @@ source=("git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd dotfiles
+ cd dotfiles || exit
git describe --tags "$(git rev-list --tags --max-count=1)" | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd dotfiles
+ cd dotfiles || exit
git fetch --tags
latest_release=$(git describe --tags "$(git rev-list --tags --max-count=1)")
git checkout "${latest_release}"
- PKGNAME=dots
- PKGDIR="${pkgdir}"
- export PKGDIR PKGNAME
- ./install
+ cd ..
+
+ if [[ ! -d "${HOME}/.local/share/chezmoi" ]]; then
+ cp -rf ./dotfiles ~/.dotfiles
+ fi
+
+ chezmoi init --apply --verbose --force --source ~/.dotfiles
}