summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e77d134cb5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
+_pkgname=dumb-init
+pkgname=$_pkgname-git
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="A minimal init system for Linux containers"
+arch=('x86_64')
+url="https://github.com/Yelp/dumb-init"
+license=('MIT')
+provides=('dumb-init')
+makedepends=('git')
+source=("git+https://github.com/Yelp/dumb-init.git")
+sha1sums=('SKIP')
+
+build() {
+ cd $srcdir/$_pkgname
+ make
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ install -m755 -D $_pkgname $pkgdir/usr/bin/$_pkgname
+ install -m644 -D LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
+}