summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9caf553f7494..36ba9dc4fe1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dust-emu-git
_pkgname=dust
-pkgver=0
+pkgver=r210.618a418
pkgrel=1
pkgdesc='A Nintendo DS emulator written in Rust for desktop devices and the web, with debugging features and a focus on accuracy'
url=https://github.com/kelpsyberry/dust
@@ -22,6 +22,11 @@ prepare() {
cargo fetch --locked --target $CARCH-unknown-linux-gnu
}
+pkgver() {
+ cd $_pkgname
+ printf r%s.%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
build() {
cd $_pkgname
cargo build --frozen --profile ci --features=dldi --package dust-desktop