summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3dbcbd854cc..adaa3069a6c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_grub4dos_version=0.4.5
pkgname='easy2boot'
-pkgver='2.13'
+pkgver='2.19'
pkgrel='1'
pkgdesc='Highly-configurable USB drive multiboot software with support for Secure UEFI booting'
url='http://www.easy2boot.com/'
@@ -13,32 +13,37 @@ arch=('any')
license=('custom:easy2boot license')
depends=()
makedepends=('dos2unix' 'jq')
-install=$pkgname.install
+install="$pkgname.install"
_projectName='Easy2Boot'
+# _projectUri="${_projectName}.html"
+# _projectId='5d01346325224d0a6d31f6d8'
_fileName="${_projectName}_v${pkgver}_password_is_e2b.zip"
source=(
"fosshub.html::https://www.fosshub.com/Easy2Boot.html/${_fileName}"
# "grub4dos.rar::http://dl.grub4dos.chenall.net/grub4dos-${_grub4dos_version}-2009-12-23.rar"
)
noextract=('fosshub.html')
-md5sums=('5354ccec82caa19e59b183fa8e3eef65')
+md5sums=('SKIP')
prepare() {
json=$(cat fosshub.html | sed -n 's/.*var.*settings.*=//p' | jq)
- projectId=$(echo ${json} | jq '{projectId: .projectId}')
+ # projectId=$(echo ${json} | jq '{projectId: .projectId}')
tempJson=$(echo ${json} | jq --arg _fileName ${_fileName} '.pool.f[] | select(.n==$_fileName) | {fileName: .n, releaseId: .r}')
+ tempJson2=$(echo $json | jq '.pool | {projectId: .p, source: .c, projectUri: .u}')
# echo ${tempJson}
- postData=$(echo ${projectId} ${tempJson} '{"projectUri": "${_projectName}.html","source":"CF"}' | jq -s 'add')
+ postData=$(echo $tempJson $tempJson2 | jq -s 'add')
# echo $postData | jq
_url=$(wget -O- --post-data="${postData}" --header='Content-Type:application/json' https://api.fosshub.com/download/ | jq '.data.url' | sed -e 's/^"//' -e 's/"$//')
+ # _url=$(wget -O- --post-data="${postData}" --header='Content-Type:application/json' https://api.fosshub.com/download/ | sed -n 's/.*"data"://p' | jq '.url')
+
# _url=${_url:}
# echo $_url