summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc837843d443..53d0dd906f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
# Maintainer: Eddie.website <maintainer@eddie.website>
# Based on work by Uncle Hunto <unclehunto äτ ÝãΗ00 Ð0τ ÇÖΜ> and Beini <bane aτ iki dot fi>
+# Current issues:
+# - msbuild vs xbuild
+# - target framework not v4.8
+
pkgname=eddie-ui
-pkgver=2.21.6
+pkgver=2.21.8
pkgrel=1
pkgdesc='Eddie - VPN tunnel - UI'
arch=('i686' 'x86_64')
url=https://eddie.website
license=(GPLv3)
-depends=(mono openvpn sudo desktop-file-utils libnotify libappindicator-gtk2)
+depends=(mono openvpn sudo desktop-file-utils libnotify libayatana-appindicator patchelf)
optdepends=('stunnel: VPN over SSL' 'openssh: VPN over SSH')
makedepends=('cmake')
provides=('eddie-ui')
conflicts=('airvpn' 'airvpn-beta-bin' 'airvpn-git')
install=eddie-ui.install
-source=('https://github.com/AirVPN/Eddie/archive/2.21.6.tar.gz')
-sha1sums=('c63513cd1da4adf2ba109c3334221d66170b226f')
+source=('https://github.com/AirVPN/Eddie/archive/2.21.8.tar.gz')
+sha1sums=('b6a2cb24858ea7ce14906901e6c92fd923a81f2c')
case "$CARCH" in
i686) _pkgarch="x86"
@@ -42,19 +46,10 @@ build() {
xbuild /verbosity:minimal /p:TargetFrameworkVersion="v4.5" /p:Configuration="Release" /p:Platform="$_pkgarch" src/eddie2.linux.ui.sln
fi
- # Compile C sources (Tray)
- # Removed in 2.21.5, compatibility issue
- #if [ "ui" = "ui" ]; then
- # cd src/UI.GTK.Linux.Tray
- # cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_LIBRARY_OUTPUT_DIRECTORY=.
- # make
- # strip -S --strip-unneeded -o eddie-tray-strip eddie_tray
- # cd ../..
- #fi
-
# Compile C sources
chmod +x src/eddie.linux.postbuild.sh
chmod +x src/Lib.Platform.Linux.Native/build.sh
+ chmod +x src/UI.GTK.Linux.Tray/build.sh
if [ "ui" = "cli" ]; then
src/eddie.linux.postbuild.sh "src/App.CLI.Linux/bin/$_pkgarch/Release/" ui $_pkgarch Release
@@ -94,7 +89,7 @@ package() {
install -Dm755 "src/App.Forms.Linux/bin/$_pkgarch/Release/App.Forms.Linux.exe" "$pkgdir/usr/lib/eddie-ui/eddie-ui.exe"
install -Dm644 "src/App.Forms.Linux/bin/$_pkgarch/Release/Lib.Forms.dll" "$pkgdir/usr/lib/eddie-ui/Lib.Forms.dll"
install -Dm644 "src/App.Forms.Linux/bin/$_pkgarch/Release/Lib.Forms.Skin.dll" "$pkgdir/usr/lib/eddie-ui/Lib.Forms.Skin.dll"
- #install -Dm755 "src/UI.GTK.Linux.Tray/eddie-tray-strip" "$pkgdir/usr/lib/eddie-ui/eddie-tray"
+ install -Dm755 "src/UI.GTK.Linux.Tray/bin/eddie-tray" "$pkgdir/usr/lib/eddie-ui/eddie-tray"
install -Dm644 "repository/linux_arch/bundle/eddie-ui/usr/share/pixmaps/eddie-ui.png" "$pkgdir/usr/share/pixmaps/eddie-ui.png"
fi