summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5bc72699f35..edca18581e2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=emacs-epc
pkgver=0.1.1
-pkgrel=3
+pkgrel=4
pkgdesc="An RPC stack for Emacs Lisp"
url="https://github.com/kiwanami/emacs-epc"
arch=('any')
@@ -10,16 +11,16 @@ license=('GPL3')
depends=('emacs' 'emacs-ctable' 'python-epc' 'emacs-deferred')
makedepends=('git')
provides=('emacs-epc')
-source=("https://github.com/kiwanami/emacs-epc/archive/${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kiwanami/emacs-epc/archive/${pkgver}.tar.gz")
sha256sums=('SKIP')
build() {
- cd "${srcdir}/emacs-epc-${pkgver}"
+ cd emacs-epc-${pkgver}
emacs -q --no-splash -batch -L . -f batch-byte-compile epc*.el
}
package() {
- cd "${srcdir}/emacs-epc-${pkgver}"
- install -d "${pkgdir}/usr/share/emacs/site-lisp/epc"
- install -m644 epc*.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/epc/"
+ cd emacs-epc-${pkgver}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/epc
+ install -m644 epc*.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/epc/
}