summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 10 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02637a324844..2392bcfaffd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,19 @@
-# Maintainer: Megameneer (Dennis Holierhoek) <dennis.hh@hotmail.com>
+# Maintainer: prg <prg _at_ xannode.com>
+# Contributor: Megameneer (Dennis Holierhoek) <dennis.hh@hotmail.com>
pkgname=esrpatch
pkgver=02
-pkgrel=4
+pkgrel=5
# This line is way over 80 characters, but a clear description for this rather specific tool is hard to make any shorter than this.
pkgdesc="A tool to patch DVD disc images for the Sony PlayStation 2 game console to make them burnable and working with ESR, an app for the PlayStation 2 made to play those burned games without swapping"
arch=('any')
-url=http://psx-scene.com/forums/f164/esr-public-beta-58441/
+url='http://psx-scene.com/forums/f164/esr-public-beta-58441/'
license=('GPL')
depends=()
makedepends=('w3m')
-source=()
-
-prepare() {
- # A dirty hack to download the package; using W3m to dump the data at the download URL instead of using the usual PKGBUILD way due to 403 (forbidden) errors when done so.
- cd "$srcdir"
- echo "Downloading esrpatch-$pkgver.tar.gz and validating it using md5sum..."
- w3m -dump_source http://psx-scene.com/forums/attachments/f164/14193d1214904456-esr-public-beta-esrpatch-02.tar.gz > esrpatch-"$pkgver".tar.gz || (echo "Downloading esrpatch-$pkgver.tar.gz failed" >&2 ; exit 1)
- if [ $(md5sum esrpatch-02.tar.gz | head -c 32) = "bc6ec554c5cbe33cab6502b50c404a58" ];
- then {
- echo "Downloaded esrpatch-$pkgver.tar.gz and successfully validated it using md5sum"
- echo "Validating esrpatch-$pkgver.tar.gz using sha256sum...";
- if [ $(sha256sum esrpatch-02.tar.gz | head -c 64) = "9cddd307b2a0ca5f048797c94309700d1dcbf3cfc570e5fab60e5ae6c798ad9f" ];
- then {
- echo "Suddessfully validated esrpatch-$pkgver.tar.gz using sha256sum"
- echo "Unpacking esrpatch-$pkgver.tar.gz...";
- tar xzvf esrpatch-"$pkgver".tar.gz || (echo "Unpacking esrpatch-$pkgver.tar.gz failed" >&2 ; exit 1);
- echo "Unpacked esrpatch-$pkgver.tar.gz"
- };
- else echo "Validating esrpatch-$pkgver.tar.gz using sha256sum failed" && exit 1;
- fi;
- };
- else echo "Downloading esrpatch-$pkgver.tar.gz or validating it using md5sum failed" && exit 1;
- fi;
-}
+# Backup mirror
+#source=('http://xannode.com/esrpatch-$pkgver.tar.gz')
+source=("https://www.psx-place.com/attachments/esrpatch-$pkgver-tar-gz.12843")
+sha256sums=('9cddd307b2a0ca5f048797c94309700d1dcbf3cfc570e5fab60e5ae6c798ad9f')
build() {
cd esrpatch
@@ -43,3 +24,5 @@ package() {
cd "$srcdir"/esrpatch
install -D esrpatch "$pkgdir"/usr/bin/esrpatch
}
+
+# vim: set ts=8 sw=8 tw=0 noet :