summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09069ad2cb32..c07f0d101538 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
_pkgname=frhelper
pkgname="eusoft-${_pkgname}-bin"
-pkgver=2024.01.16
+pkgver=2024.02.27
pkgrel=1
pkgdesc="法语助手,权威的法语词典软件,法语学习者必备的工具.支持学习笔记、生词本多平台同步,让你随时随地学法语."
arch=('x86_64')
@@ -56,24 +56,23 @@ depends=(
'aalib'
'libshout'
'twolame'
- 'taglib'
'libsoup'
'wavpack'
'libcaca'
)
source=(
"${pkgname%-bin}-${pkgver}.deb::https://www.eudic.net/download/${_pkgname}.deb?v=${pkgver//./-}"
- "LICENSE.html"
+ "LICENSE.html::https://dict.eudic.net/home/privacy"
"${pkgname%-bin}.sh"
)
sha256sums=('ce5fcba8f0a2ffd0bff6b62e63f658883e795577caca130698de799a8647530c'
- '69031e95591a339c4cd9c01547494e23196cea6438608f1f951b493ea8fca54f'
+ '21e001fde21fdd190dd3fd47ca496be4bd945955d96f0987bccf059e5643b344'
'c68de8f6be6059bc0019b5d2ef43edfabe15bd2c213d671ca39ed69ae0619c66')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|${_pkgname}|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|/usr/share/${pkgname%-bin}/AppRun|${pkgname%-bin}|g;s|com.eusoft.${_pkgname}|${pkgname%-bin}|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}