summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 24 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14ba23c7b6b2..12e96529018c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,35 @@
_pkgname=exaile
pkgname=${_pkgname}-git
epoch=1
-pkgver=4.0.0rc5+0+g449775a8
+pkgver=4.1.3beta3+11+g1994772c
pkgrel=1
pkgdesc="music player for gnome, similar to KDEs amarok"
-arch=('x86_64' 'i686')
-url="http://www.exaile.org"
+arch=('any')
+url="https://www.exaile.org"
license=('GPL')
-depends=('gtk3' 'python2-mutagen' 'python2-dbus' 'python2-gobject'
- 'python2-cairo' 'udisks2' 'librsvg' 'gst-plugins-good')
-makedepends=('git')
-optdepends=('python2-feedparser: podcasts plugin'
+depends=('gtk3' 'python-bsddb' 'python-mutagen' 'dbus-python' 'python-gobject'
+ 'python-cairo' 'udisks2' 'librsvg' 'gst-plugins-good')
+makedepends=('git' 'help2man')
+optdepends=('python-feedparser: podcasts plugin'
'webkit2gtk: wikipedia plugin'
- 'python2-lxml: LyricsMania plugin'
- 'cddb-py: look up CD tags'
+ 'python-lxml: LyricsMania plugin'
'libkeybinder3: Multimedia keys plugin'
- 'python2-beautifulsoup4: Lyrics Wiki plugin'
+ 'python-beautifulsoup4: Lyrics Wiki plugin'
'libnotify: Notify plugin'
'streamripper: Streamripper plugin'
'gnome-screensaver: Pause on screensaver plugin'
'mate-screensaver: Pause on screensaver plugin'
'cinnamon-screensaver: Pause on screensaver plugin'
- 'python2-musicbrainzngs: Musicbrainz cover search plugin'
- 'ipython2: Ipython console plugin'
- 'python2-pylast: Last.fm loved tracks plugin'
+ 'xfce4-screensaver: Pause on screensaver plugin'
+ 'moodbar: Moodbar plugin'
+ 'python-musicbrainzngs: Musicbrainz cover search plugin & CD tags plugin'
+ 'python-discid: CD tags plugin'
+ 'ipython: Ipython console plugin'
+ 'python-pylast: Last.fm loved tracks plugin'
'gst-plugins-bad: Additional audio codecs'
'gst-plugins-ugly: Additional audio codecs'
'spydaap-git: DAAP server/client')
-
+checkdepends=('python-pytest')
provides=("${_pkgname}=${pkgver%%+*}")
conflicts=("${_pkgname}")
source=("${_pkgname}"::git+https://github.com/exaile/exaile.git)
@@ -38,16 +40,21 @@ sha256sums=('SKIP')
pkgver() {
cd "${_pkgname}"
- git describe --long --tags | sed 's/-beta/.beta/;s/-rc/rc/;s/-/+/g'
+ git describe --long --tags | sed 's/-beta/beta/;s/-alpha/alpha/;s/-rc/rc/;s/-/+/g'
}
build() {
cd "${_pkgname}"
- make
+ make PREFIX="/usr"
+
+}
+
+check() {
+ cd "${_pkgname}"
+ make PYTEST="py.test" test
}
package() {
cd "${_pkgname}"
make DESTDIR="$pkgdir/" PREFIX="/usr" install
- make clean
}